It's all about the answers!

Ask a question

Why do I get "Permission denied" when trying to create a comment for a work item using the OSLC API?

Fabian Zaiser (2336) | asked Aug 04 '16, 5:54 a.m.
edited Aug 04 '16, 9:47 a.m.
EDIT: This seems to have been a problem with the Firefox RESTClient extension. Accessing the URI from Java did work (cf. my answer). So the problem is solved for me. /EDIT

I'm trying to create a comment for a work item on the RTC cloud trial (, using the OSLC API, following

What I did: I sent a POST request to the URI "[...]/rtc_cm:comments/oslc:comment" with the following body
"dcterms:description": "test comment"

What happened: I got the response status code "403 Permission denied" and the message "Your account does not have the group memberships required to access the requested resource.". However, I'm an administrator for this project and in the settings I gave myself all the permissions I could find.

Do you have any ideas why that might be? (I'm new to RTC, so I may be missing something obvious.)

One answer

permanent link
Fabian Zaiser (2336) | answered Aug 04 '16, 9:43 a.m.
So I tested the above using the Firefox RESTClient extension and it didn't work. Doing it from Java directly did work for some reason. This still doesn't explain why but at least it's not a problem for me anymore.

Your answer

Register or to post your answer.