It's all about the answers!

Ask a question

[closed] Resuming suspended changesets in stream not working


Lauren Hayward Schaefer (3.3k11127) | asked May 19 '15, 9:57 a.m.
JAZZ DEVELOPER
edited May 26 '15, 1:12 p.m. by Martha (Ruby) Andrews (3.0k43550)
My situation:  My project was originally in CVS.  The project and all of its history was transferred to Jazz Source Control about 2 years ago.  The team made changes to the code in Jazz Source Control.

What I'm trying to do:  Revert my repo workspace to the beginning of its history, so I can choose to pull in changes from the project's original history.

Steps I followed:
  1. Create a new repository workspace
  2. In the Pending Changes view, right click on the component and select Show > History
  3. Select all of the history
  4. Right click and select Suspend
  5. Return to the Pending Changes view
  6. Right click on the bottom-most (oldest) changeset and select Resume

Expected:  The changeset is incorporated into my repository workspace, and the changeset is no longer listed in the Suspended view.

Actual:  A dialog showing "Operation in progress" briefly appears and then nothing changes.  The changeset is still listed in the Suspended view.

----

I've also tried to accept the changeset using the command line:

lscm resume changeset [myuuid]

The output is:

Resuming change sets:
Workspace unchanged.

----

When I run lscm status, I can see the change sets that were created after the transition to RTC have aliases:

(1697) ----$ 'info about my changeset'

However, the changeset I'm trying to resume that was migrated from CVS does not have an alias:

(----) ----% 'info about my changeset'

----

Instead of suspending the changes, I've also tried discarding the changesets, but as I describe in https://jazz.net/forum/questions/184986/how-can-i-revert-repository-workspace-back-in-time, the changesets that were migrated from CVS are not listed as Incoming changes.

----

I'm unsure if this is a defect or I'm completely missing something.  Any advice on how to resume the changesets or get the changesets to display as Incoming after discarding would be appreciated.

The question has been closed for the following reason: "Problem is not reproducible or outdated" by lhayward May 19 '15, 10:45 a.m.