It's all about the answers!

Ask a question

RTC 5.0.2/ Jenkins integration : RTC does not connect to Jenkins 1.585 and higher on https port?


Sunil Kumar R (1.1k13244) | asked Feb 05 '15, 11:07 a.m.
JAZZ DEVELOPER
edited Feb 05 '15, 11:13 a.m.
The https connection from RTC eclipse client 5.0.2 {RTC v5.0.2 server} fails for Jenkins 1.598 [v1.585 and higher]. But the same works fine for Jenkins 1.584.

I would like to know if you have encountered the same and fixed it?

Steps to reproduce:
a. On the CLM 5.0.2 server / a different machine accessible to RTC eclipse and RTC 5.0.2 server, download the Jenkins plugins 1.584 and 1.598.

b. Start Jenkins (say for Jenkins 1.584 jenkins.war) using command :
java -jar jenkins.war --httpsPort=8443 &

c.1. Now, create a Hudson/Jenkins build engine in RTC 5.0.2 client and try 'Test Connection'.
 >> you will see test connection succeeded.

Steps b and c.1 with Jenkins 1.598 (in general 1.585 and higher) jenkins.war file does not work and leads to error as below.


>> But, test connection on http port 8080 works fine.

Accepted answer


permanent link
Lakshmi Narasimhan T V (4415) | answered Feb 09 '15, 12:14 p.m.
JAZZ DEVELOPER
Hi
Could you add the following system property to your server, restart it and check whether you are able to connect to the Jenkins server?
-Dhttps.protocols=TLSv1
If you are using Tomcat, this property can be added to the server.startup script.

Sunil Kumar R selected this answer as the correct answer

Comments
Sunil Kumar R commented Feb 09 '15, 1:20 p.m.
JAZZ DEVELOPER

Hi Lakshmi, thank you for inputs.. I tried using Java opts in server.startup..

-Djazz.connector.sslProtocol=TLSv1, -Dhttps.protocols=TLSv1
Connection test requested.
Connecting to: https://clm502:8443
Exception: java.io.IOException: HTTPS hostname wrong:  should be <clm502>
  Test connection FAILED!

I also checked using the machines hostname, but error stays..
My search on above indicates its related to certificate(?) I could be wrong..

Also changes in server.xml tried changes as per https://access.redhat.com/solutions/1232233 renders similar results..

Now in all such cases, connect to jenkins works well on browser.

Best Regards
Sunil


Lakshmi Narasimhan T V commented Feb 09 '15, 11:03 p.m.
JAZZ DEVELOPER

In the Hudson Jenkins build engine definition, could you uncheck "Validate Hostname" and test the connection?


Sunil Kumar R commented Feb 10 '15, 2:44 a.m.
JAZZ DEVELOPER

 That works! In summary..

1) Add the following lines to server.startup.bat / startup script:

set JAVA_OPTS=%JAVA_OPTS% -Djazz.connector.sslProtocol=TLSv1
set JAVA_OPTS=%JAVA_OPTS% -Dhttps.protocols=TLSv1
2) Uncheck Validate hostname option on Jenkins Build Engine Definition



One other answer



permanent link
Krishna Kishore (50112) | answered Feb 09 '15, 4:13 a.m.
JAZZ DEVELOPER
 Hi,

Are you able to access https://clm502:8443 from a web browser and using curl, the curl command is 

curl -k -v -u USER_ID:PASSWORD JENKINS_URL -o out.txt

where JENKINS_URL is as configured in the build engine, and see which response code and headers come back, e.g. normal case is:

< HTTP/1.1 200 OK

< X-Hudson: 1.395

< X-Jenkins: 1.598

Thanks,

Kishore


Comments
Sunil Kumar R commented Feb 09 '15, 6:55 a.m.
JAZZ DEVELOPER

 Hi Krishna, yes - the headers received have a HTTP 200 and the jenkins https URL loads well on browser.


Here is how the 'Response Headers' look for GET on https://clm502:8443 on RESTClient. So I am a little concerned where the issue might be?
Is RTC 5.0.2 or is it Jenkins 1.598 that has changed.

[Left : for Jenkins 1.598]                                                     [Right : for Jenkins 1.584]
 >> difference : Jetty-winstone-2.8      v/s           Jetty-winstone-2.5

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.