RTC 5.0.2/ Jenkins integration : RTC does not connect to Jenkins 1.585 and higher on https port?
The https connection from RTC eclipse client 5.0.2 {RTC v5.0.2 server} fails for Jenkins 1.598 [v1.585 and higher]. But the same works fine for Jenkins 1.584.
I would like to know if you have encountered the same and fixed it?
Steps to reproduce:
a. On the CLM 5.0.2 server / a different machine accessible to RTC eclipse and RTC 5.0.2 server, download the Jenkins plugins 1.584 and 1.598.
b. Start Jenkins (say for Jenkins 1.584 jenkins.war) using command :
java -jar jenkins.war --httpsPort=8443 &
c.1. Now, create a Hudson/Jenkins build engine in RTC 5.0.2 client and try 'Test Connection'.
>> you will see test connection succeeded.
Steps b and c.1 with Jenkins 1.598 (in general 1.585 and higher) jenkins.war file does not work and leads to error as below.
>> But, test connection on http port 8080 works fine.
Accepted answer
Hi
Could you add the following system property to your server, restart it and check whether you are able to connect to the Jenkins server?
-Dhttps.protocols=TLSv1
If you are using Tomcat, this property can be added to the server.startup script.
Could you add the following system property to your server, restart it and check whether you are able to connect to the Jenkins server?
-Dhttps.protocols=TLSv1
If you are using Tomcat, this property can be added to the server.startup script.
Comments
One other answer
Hi,
Are you able to access https://clm502:8443 from a web browser and using curl, the curl command is
curl -k -v -u USER_ID:PASSWORD JENKINS_URL -o out.txt
where JENKINS_URL is as configured in the build engine, and see which response code and headers come back, e.g. normal case is:
< HTTP/1.1 200 OK
< X-Hudson: 1.395
< X-Jenkins: 1.598
Thanks,
Kishore