It's all about the answers!

Ask a question

Replacement for Deprecated Kinds


Pooja Biwalkar (481124) | asked Jan 26 '15, 10:09 a.m.
 Hi,

The 'Checkbox Multi-Select List' kind is not supported anymore in RTC.We have an Attribute called 'DataStore' of type smallString and kind is 'Checkbox Multi-Select List'  but that kind is not supported anymore.

Which is the best way to change the kind and make sure that the already existing attributes are not hampered and inherit the new kind?

Accepted answer


permanent link
Ralph Schoon (60.9k33643) | answered Jan 26 '15, 11:54 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi,

You would have to introduce a new attribute of the List[your_old_type]. If your type is based on an enumeration, you can create such an attribute. Your old data would still be in the old attribute.

Using https://www.google.de/search?q=multiselect+upgrade+site:jazz.net I was able to find this https://jazz.net/library/article/1458 work around that might be helpful.
Pooja Biwalkar selected this answer as the correct answer

Comments
Pooja Biwalkar commented Jan 26 '15, 1:25 p.m.

 Thanks Ralph.I did try out that option but somehow the old values are not getting updated.XML generated with the CSV file is not correct I guess,I am still working on that though.Is there any other workaround as well? 


Ralph Schoon commented Jan 27 '15, 2:19 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

You need to get the mapping right.

This is the only approach, except you want to do custom API programming - which will be more effort.


Pooja Biwalkar commented Jan 29 '15, 11:31 a.m.

  Hi Raplh,


It works perfect when we have just one value in the CSV.But when more than one value is added,it doesn't like it.Below is the file that is generated by RTC when you export the query and the work item has multiple values.They are separated by comma,even though it says 'tab' is the delimiter. Can you please check and let me know if the syntax in the CSV file is accurate. 





Pooja Biwalkar commented Jan 29 '15, 11:32 a.m.

 This is how the CSV looks-   



Type Id Datastore New Datastore
Asset 888 UTL,FIA UTL
Asset 891 FIA,FSA FIA
Asset 889 ORD,UTL ORD

One other answer



permanent link
Ralph Schoon (60.9k33643) | answered Jan 30 '15, 3:13 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
In the old version, the enumeration values were stored as a comma separated list.
If you export the new format with values (default settings), you will notice, that the enumeration list values are separated by a line break.

I would suggest to
  1. Export the values
  2. Rename the column
  3. Replace the comma (,) by a line break - all values need to be enclosed in quotes
  4. Start the importer, generate a default mapping file
  5. Import using the mapping file

I tried to export an enumerationList that way and imported into a new work item and it worked for me.

Your answer


Register or to post your answer.