It's all about the answers!

Ask a question

zLinux scm in lscm command shows floating point exception


Arul Dhandapani (634) | asked Nov 15 '14, 3:38 a.m.
edited Nov 15 '14, 3:38 a.m.
I download "SCM Tools - Linux for System Z" for zLinux from "plain .zip" location in "https://jazz.net/downloads/rational-team-concert/releases/5.0?p=allDownloads" link.

After that I extracted below the location and I verified status using lscm, Now I got Floating point exception I tried with "fec -v" then I received "Floating point exception" error.

/opt/IBM/TeamConcert/scmtools/eclipse # ./lscm status
./lscm: line 28: 15129 Floating point exception"${PRGPATH}/fec" "$@"

Here, which one I missed and why it's not showing version number..?

3 answers



permanent link
Shashikant Padur (4.2k27) | answered Nov 17 '14, 12:56 a.m.
JAZZ DEVELOPER
edited Nov 17 '14, 12:56 a.m.
Arul,
Not sure why it is showing a floating point exception. Can you try setting an environment variable LSCM_USE_JAVA_FEC to any value say 1 and run the command again? If you still see some errors run 'scm daemon stop -a' and then re-run the lscm command.

Comments
Arul Dhandapani commented Nov 17 '14, 4:04 a.m.

 Hi Shashikant


Thanks for reply my post.

I tried with your suggestion but it's not working and even there is no 'scm daemon' running in my machine.

Here's my problem when I run ./fec -v in zLinux server I received "Floating point exception" but in Ubtuntu server it's works well.


permanent link
Arul Dhandapani (634) | answered Nov 17 '14, 4:15 a.m.
For additional informaiton, We used below the version zLinux and Java server.  
SUSE Linux Enterprise Server 10 (s390x)
VERSION = 10
LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-s390x:core-3.0-s390x"
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
Classic VM (build 1.4.2, J2RE 1.4.2 IBM build cxz64142ifx-20060209 (SR4-1) (JIT enabled: jitc))


Comments
Shashikant Padur commented Nov 17 '14, 5:16 a.m. | edited Nov 17 '14, 5:19 a.m.
JAZZ DEVELOPER

Arul,

You should not be using fec binary. Always use lscm. I hope you tried the above suggestion with lscm and not fec.

Also, Java version must be 1.6.


Arul Dhandapani commented Nov 17 '14, 5:30 a.m.

Hi Shashikant


I tried but it's not working.

Still it's shows "./lscm: line 28: 15129 Floating point exception"${PRGPATH}/fec" "$@" " so I just try "fec -v" if it's works.

So in my scenario what was the problem where I missed.? do you have any idea..?


permanent link
Alan Sampson (93729) | answered Nov 17 '14, 10:07 a.m.
JAZZ DEVELOPER
I have a suspicion it's your Java version.  I'm pretty sure Java 1.4.2 is not supported.  The system requirements documentation indicates that Java 1.6 is required for CLM 5.0: https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements50#A9_Java_Runtime_Environment_Serv

Your answer


Register or to post your answer.