It's all about the answers!

Ask a question

Web UI not listing complete change set


Vince Thyng (13723953) | asked Jul 15 '14, 5:09 p.m.
edited Jul 15 '14, 5:23 p.m.
I have a report of the web interface showing an incomplete list of files in a changeset.  Through the eclipse and Visual Studio clients, the changeset is complete.
29 files changed, but only 2 showing up in the web interface.
incomplete changeset
complete changeset
Possible culprits:
We just upgraded this repository from 4.0.2 to 4.0.6 over the weekend.  This issue was reported after the upgrade.
Related to the upgrade, we are now getting "Problems serving sprite image service request" that appears to have been an issue in 4.0.1, fixed in 4.0.3, and I saw reports of this error logged in 4.0.5 and my 4.0.6 still.  I see it being logged when I load the work item in the web UI, but not when I load the changeset webpage.

I tried to add pictures of the problem.  Not sure if they are coming through though.

I have tried in IE and FF, same incomplete list.


Comments
1
Ralph Schoon commented Jul 16 '14, 2:46 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would suggest to open a PMR with support.

2 answers



permanent link
Vince Thyng (13723953) | answered Aug 04 '14, 12:04 p.m.
Rational Support was able to figure out what was happening.  The web ui only shows modifications to file content and not changes to file properties, when viewing a change set.  There is an enhancement work item to also show files in a change set where only their properties have been changed.
https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=126139

permanent link
Vince Thyng (13723953) | answered Aug 11 '14, 11:40 a.m.
Actually, this ended up being a bug in a very specific scenario.
https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=327229
They have discovered the problem and fixed it, targetting the 5.0.2 release.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.