It's all about the answers!

Ask a question

Why SCM Command Line is automatically taking another repository for some command?


Shuchita Tripathi (30423180) | asked May 23 '14, 3:11 a.m.
edited May 23 '14, 4:59 a.m. by Ralph Schoon (55.5k23642)

I am facing 2 issues with command line scm, and i am not able to proceed because of them.

1. If any command doesnot have '-r' as option, it is automatically taking any other repository or project (which I havent provided) and that command is failing.

For eg: scm checkin .

It is saying that a particular 'test' folder is not present for checking in. 'Test' folder was for some other project and i used it 2 days back.

Similarly, if I am trying in other machines, it is connecting to a particular repository which is for our official use.

I am trying everything in an instance which is local to my system (localhost). Not able to proceed due to this.

Logining in to localhost

2. SCM CLI is taking username as the one from which I logged in to my system and then asking password. It is not taking the username which I provided for RTC. For eg: if i logged in to my system using my ID '123' and my RTC pwd is 'abcd', it is asking me password for repository, with username '123'.

Any help is highly appreciated.


Comments
Krzysztof Kaźmierczyk commented May 23 '14, 4:26 a.m.

Hi Shuchita,
It is really difficult for me what is written on first screen snapshot. This message might be significant. Could you please paste the content in text mode?


Shuchita Tripathi commented May 23 '14, 4:55 a.m.

In the first screenshot, i have just shown that i am logging in to localhost:9443/ccm using username and password. An error msg (Job found still running after platform shutdown) is coming but i got a work item for that stating it will be fixed in v5.0.1.


Shuchita Tripathi commented May 23 '14, 4:57 a.m.

Here is another screenshot for the issues i have raised.

I have logged in with user name as 'admin' in local host, but when i am running status it is asking me the password of different repository (official purpose related) with the user id of my system.

Accepted answer


permanent link
Tim Mok (6.6k38) | answered May 23 '14, 7:49 a.m.
JAZZ DEVELOPER
Did you ever unload the repository workspace for that "Test" project? It looks like it's still loaded or there is still some RTC metadata in the sandbox that is conflicting with what you currently have loaded. Try clearing your sandbox and reloading the repository workspace or unloading that other repository workspace used for the "Test" project.

Also, it appears you are loading content into the same location as where the CLI was installed. I don't recommend doing this since you would be loading your repository workspace into an area where there are existing files. It may get confusing if you refresh the sandbox and it starts adding the CLI install to your unresolved changes.
Shuchita Tripathi selected this answer as the correct answer

Comments
Shuchita Tripathi commented May 23 '14, 9:19 a.m.

Thanks Tim for your response.

I manually deleted the Test project. After that i am checking in using 'scm checkin <folder_name> and it is working that way. Will try the unload method also.

I am able to load the component only where .jazz5 folder is present. Earlier it was present in C:\IBM\RTC so I wasnt able to load the files. So i copied from there and pasted in the current folder. After that I was able to load in the current folder. Is this the right way?

Also, can you please guide me on the second issue I have raised? Why it is taking another repository for few commands?

In the below image, 'abcd' is the nick name of localhost:9443/ccm

It is running perfectly for list snapshot command, but not for 'diff' command. There are many other examples like this.

Can you please guide.

scm


Tim Mok commented May 23 '14, 11:05 a.m.
JAZZ DEVELOPER

The .jazz5 folder should not be copied around or modified by anything other than the RTC client. It's likely the copying of this folder that is creating your issue with the wrong repository being contacted.

You should be able to load to where you specify and it will create the .jazz5 metadata folder. If you can't, there's some sort of issue that you'll have to provide more information to determine the cause.


Shuchita Tripathi commented May 26 '14, 1:27 a.m.

Hi Tim,

Can you please tell me what more information I can provide?

Our main concern right now is that it is automatically logging in into different repository. How to stop that? I tried to logout from the second repository but it is not working.


1
Tim Mok commented May 26 '14, 8:33 a.m.
JAZZ DEVELOPER

It would be nice to know what the outcome of loading in a new sandbox without copying the .jazz5 folder as well as not loading into an existing CLI install. If you still can't get it working, post the full log of the commands that you ran. Everything from creating the directory of where you want to load your content to loading your content to where you encounter the issue.


Shuchita Tripathi commented May 27 '14, 4:41 a.m.

Hello Tim,

I am now able to load the files in a new sandbox without copying .jazz5 folder.

Thank you!!

Can you please tell me about the second issue?

What could be the possible reason that cli is logging into different repository? I tried to logout from it but it is not working. Error message says that the server is not reachable.


Tim Mok commented May 27 '14, 8:02 a.m.
JAZZ DEVELOPER

My only guess is what I said earlier:

The .jazz5 folder should not be copied around or modified by anything other than the RTC client. It's likely the copying of this folder that is creating your issue with the wrong repository being contacted.


Shuchita Tripathi commented May 27 '14, 8:36 a.m.

Thanks for your help Tim.

I'll update the issue if I get an answer.

showing 5 of 7 show 2 more comments

Your answer


Register or to post your answer.