It's all about the answers!

Ask a question

How do I run an 'scm load' command and have it load into a directory structure like C:\A\B\C?


Frank Brewer (547) | asked Apr 15 '14, 11:39 a.m.

I am running in a Windows environment.

I ran the following command successfuly for months and then something changed (Iand I started getting an error message:

cd C:\A\B\C

scm load -r http://repository-uri -u user -P password my_repository_workspace

The error message that I get (that has been identified in this forum previously) is the following:

Problem runinng 'load'

Must load in sandbox root (C:\). To load into a descendant specify the path with target.  Try 'scm help load" for more information.

From what I read in this forum and the various papers associated with 'scm load' that I was directed to in this forum, I wound up adding a "-d" option with path where the load should be placed.  Unfortunately, using the "-d" option did not change anything.  I got the very same error.

I also read something about stopping the scm daemon.  Two arguments are needed to run the 'scm daemon stop': (1) the share-root and (2) the port of the daemon to stop.  I could not figure out what the "share-root" was nor where to find the port that the scm daemaon was running on.  I went to the Task Manager in Windows and killed the scm.exe process hoping that might work but it did not solve the problem.

This question has been asked by others.  I have done a thorough search of Jazz.net but I have not seen an answer to this question that any of the askers were satisfied with.  If anyone out there has a solution to this problem I would appreciate hearing from you.  Thanks in advance.

Accepted answer


permanent link
Lily Wang (4.9k714) | answered Apr 15 '14, 7:24 p.m.
Hi Frank,
You can check if there's a ".jazz5" directory under "C:\". If there is, you can delete the "C:\.jazz5" directory and try the scm load again.
Frank Brewer selected this answer as the correct answer

Comments
Shashikant Padur commented Apr 15 '14, 11:28 p.m. | edited Apr 15 '14, 11:30 p.m.
JAZZ DEVELOPER

As Lily mentioned you have run an earlier load when in C:\ directory. You can load another repository workspace at the same level as C:\ but not below it.

If you run 'lscm status' in C:\ you may see some output with respect to the earlier load... that is if you have not manually deleted the loaded folders.
You can either urn 'lscm unload workspace' or delete the .jazz5 directory.


Frank Brewer commented Apr 16 '14, 9:30 a.m.

Thanks for the information.  This was the correct solution for the problem I mentioned.

One other answer



permanent link
Markus Selve (1013) | answered Dec 31 '14, 8:38 a.m.
I had loaded a folder and could see with "lscm status" information about the workspace, component and baseline as mentioned above.
I then did a "lscm unload -w <my workspace name>".  I verified with "lscm status" that now nothing is displayed.  The sub directory .jazz5 still exists.
Then I tried a new "lscm load" in a sub directory and contrary to what Shashikant Padur wrote on Apr 15 I still get the same error:
Must load in sandbox root (/home/...). To load into a descendant specify the path with target. Try 'lscm help load' for more information.
This points to "
specify the path with target.".  In the 'lscm help load' there is this option listed:
...
 
-t, --target <arg>            - An optional local path where changes are
                                  loaded.
...
Is that what the error messages suggests?  I tried that option it does not help solving the problem.

It may work to delete the .jazz5 sub directory.  But that obviously isn't a clean way.  There must be a way with a command to solve this.


Comments
Shashikant Padur commented Jan 05 '15, 11:28 p.m.
JAZZ DEVELOPER

Sorry for the incorrect information. The unload command does not remove the .jazz5 folder. You need to manually delete the .jazz5 folder. I agree it would help if there is something like a clean up command.

Your answer


Register or to post your answer.