It's all about the answers!

Ask a question

Project Area Configuration For OSLC?


Kartik Manchanda (767) | asked Feb 14 '14, 11:26 a.m.
edited Feb 14 '14, 11:30 a.m.
 Hello
I am running into an issue where I am able to change state transitions via OSLC (cURL PUT) in one Project Area and not the other. Is there any configuration within Project Area which can cause the above behavior?

Worth to mention : The Project Area where OSLC commands are not working was migrated from RTC 3.0.1.3 to RTC 4.0.3 version whereas the Project Area where OSLC commands are working is the one derived from one of the default template which came with RTC 4.0.3

Thanks
K..

Comments
Donald Nong commented Feb 16 '14, 8:56 p.m.

I think it's beneficial to provide more details about the issue. For example, when the PUT request failed, what error/response did you get?


Kartik Manchanda commented Feb 16 '14, 9:18 p.m.

PUT Request is successful on both the project areas. Both commands return 200 OK Status. However the state of a WI in Project Area migrated from RTC 3.0.1.3 remains same whereas state of a WI in Project Area created in RTC 4.0.3 changes as expected. One thing to notice is that WI in Project Area migrated from RTC 3.0.1.3 displays message "Refresh to get latest updates", but History shows no changes. 

Below is the PUT command

curl -D - -k -b %COOKIES% %VERBOSE% -H "Content-Type: application/x-oslc-cm-change-request+xml" -H "Accept: application/x-oslc-cm-change-request+xml" -X PUT --data-binary @97391.json http://xxx.com/ccm/resource/itemName/com.ibm.team.workitem.WorkItem/97391?_action=com.xxx.team.workitem.buildWorkflow.action.a2


Kartik Manchanda commented Feb 19 '14, 3:26 p.m.
C:\RTC\OSLC\Test>curl -D - -k -b "C:\RTC\OSLC\Test\cookies.txt" -v -H "Content-T
ype: application/x-oslc-cm-change-request+json" -H "Accept: application/x-oslc-c
m-change-request+json" -X PUT --data @622.json http://xxx.co
m/ccm/resource/itemName/com.ibm.team.workitem.WorkItem/622?_action=storyworkflow
.action.a4
* Hostname was NOT found in DNS cache
* Adding handle: conn: 0x11afa70
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x11afa70) send_pipe: 1, recv_pipe: 0
*   Trying 10.134.65.189...
* Connected to xxx.com (10.134.65.189) port 80 (#0)


Kartik Manchanda commented Feb 19 '14, 3:27 p.m.

 * upload completely sent off: 282 out of 282 bytes

< HTTP/1.1 200 OK
HTTP/1.1 200 OK
< ETag: "20861ef6-d6a2-3fa5-8fa0-2ce978b7ad52"
ETag: "20861ef6-d6a2-3fa5-8fa0-2ce978b7ad52"
< Last-Modified: Wed, xxx
Last-Modified: Wed, xxx
< Cache-Control: private, max-age=0, must-revalidate
Cache-Control: private, max-age=0, must-revalidate
< Expires: Wed, xxx
Expires: Wed, xxx
< Vary: Accept
Vary: Accept
< Content-Type: application/x-oslc-cm-change-request+json;charset=UTF-8
Content-Type: application/x-oslc-cm-change-request+json;charset=UTF-8
< Content-Language: en-US
Content-Language: en-US
< Transfer-Encoding: chunked
Transfer-Encoding: chunked
< Date: Wed, x
Date: Wed, x
* Server WebSphere Application Server/7.0 is not blacklisted


Kartik Manchanda commented Feb 19 '14, 3:27 p.m.

 Above 2 Posts describes the command used along with the outcome


Steve Speicher commented Mar 05 '14, 2:31 p.m.
JAZZ DEVELOPER

 Note: Kartik has opened Defect 305616

showing 5 of 6 show 1 more comments

One answer



permanent link
Steve Speicher (30765) | answered Feb 20 '14, 12:55 p.m.
JAZZ DEVELOPER
 Kartik,

Here are few things to try.  I seem to recall the problem is that RTC silently ignores actions it doesn't know about.  And the action ids are different from server instance to server instance, even with the same process setup (disclaimer, I'm not in RTC dev and haven't verified this...just wanted to give a couple things to try:

  1. Verify the action ids are current for the server+project you are sending the request, namely:
      ?_action=com.xxx.team.workitem.buildWorkflow.action.a2
    or
      ?_action=storyworkflow.action.a4

  2. Change to using OSLC 2.0 style requests, this can be done by setting this header:
      OSLC-Core-Version: 2.0

Hopefully someone with a bit more day-to-day hands on with RTC may be able to confirm or deny this.

Comments
Kartik Manchanda commented Feb 21 '14, 10:25 a.m.

Thanks Steve. I did take care of actions and states and took the literal values from the PA (Project Area) Source Configuration pertaining to Work Item. I did made a switch to OSLC 2.0, however with no luck. 

Below is the command with output

Command :

C:\RTC\OSLC\Test>curl -D - -k -b "C:\RTC\OSLC\Test\cookies.txt" -v -H "OSLC-Core
-Version: 2.0" -H "Content-Type: application/json" -H "Accept: application/json"


Kartik Manchanda commented Feb 21 '14, 10:27 a.m.

 Output :

Connected to xxx.com (XX) port 80 (#0)
> PUT /ccm/resource/itemName/com.ibm.team.workitem.WorkItem/628?_action=storyworkflow.action.a4 HTTP/1.1
> User-Agent: curl/7.30.0
> Host: xxx.com
> Cookie: JSESSIONID=XXXX
> OSLC-Core-Version: 2.0
> Content-Type: application/json
> Accept: application/json
> Content-Length: 587
* upload completely sent off: 587 out of 587 bytes
< HTTP/1.1 200 OK
HTTP/1.1 200 OK


Kartik Manchanda commented Feb 21 '14, 10:28 a.m.
< ETag: "08595081-5852-38d1-ac47-764ce5651106"
ETag: "08595081-5852-38d1-ac47-764ce5651106"
< Last-Modified: Fri, 21 Feb 2014 15:03:46 GMT
Last-Modified: Fri, 21 Feb 2014 15:03:46 GMT
< Cache-Control: private, max-age=0, must-revalidate
Cache-Control: private, max-age=0, must-revalidate
< Expires: Fri, 21 Feb 2014 15:03:46 GMT
Expires: Fri, 21 Feb 2014 15:03:46 GMT
< Vary: Accept, OSLC-Core-Version
Vary: Accept, OSLC-Core-Version
< Content-Type: application/json;charset=UTF-8
Content-Type: application/json;charset=UTF-8
< Content-Language: en-US
Content-Language: en-US
< Transfer-Encoding: chunked
Transfer-Encoding: chunked
< Date: Fri, 21 Feb 2014 15:03:46 GMT
Date: Fri, 21 Feb 2014 15:03:46 GMT
* Server WebSphere Application Server/7.0 is not blacklisted
< Server: WebSphere Application Server/7.0

Your answer


Register or to post your answer.