It's all about the answers!

Ask a question

[closed] Problems running Build Toolkit on Linux Jenkins Slave


Bernie Bonn (21910) | asked Dec 10 '13, 11:23 a.m.
closed May 25 '21, 7:00 a.m. by Ralph Schoon (63.0k33645)
 Hi there,

We have our Jenkins master running on Windows 2008.   We have been successful loading the build toolkit on our windows slaves and have builds going.   We now want to do the same on a Redhat linux slave.   

So now in the global config we have a windows toolkit and a Linux one listed.  The linux path in the global config looks like this: /var/appl/jenkins/rtctoolkit-4.0.1/jazz/buildsystem/buildtoolkit

On the slave the  we entered the same path in the "Tools Location".

We get the error in the job console:

FATAL: RTC : checkout failure: Built toolkit directory not found at: C:\var\appl\jenkins\rtctoolkit-4.0.1\jazz\buildsystem\buildtoolkit

Obviously there is no C: on the Redhat slave.  

We also tried the "Install Automatically" option to grab it from Artifactory and install.  But the same error persists.

Are there any tricks to getting this working with a Windows Master and Redhat agent?  I appreciate any and all help, thanks!


The question has been closed for the following reason: "The question is answered, right answer was accepted" by rschoon May 25 '21, 7:00 a.m.

3 answers



permanent link
David Honey (1.8k17) | answered May 25 '21, 5:28 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please submit a new question rather than comment on a 7+ year old question.


permanent link
Heather Fraser-Dube (4512) | answered Jun 04 '14, 9:09 a.m.
JAZZ DEVELOPER
 Sorry for the delay. The Jenkins slave needs to be configured to know where the build toolkit tool is. Team concert plugin - Slave configuration

permanent link
Charles Choi (1113) | answered May 24 '21, 5:58 p.m.
edited May 24 '21, 6:14 p.m.

 the link does not work.  I have same issue.

Master on Windows
Slave on Linux:
FATAL: RTC : checkout failure: Built toolkit directory not found at: C:\opt\IBM\TeamConcertBuild\buildsystem\buildtoolkit 

In master Tool config, RTC has:
Name: RTC Build Toolkit (Linux)
Home: /opt/IBM/TeamConcertBuild/buildsystem/buildtoolkit

In agent node, it has same settings.

In Job, it is using "RTC Build Toolkit (Linux)"