It's all about the answers!

Ask a question

How do I resolve the Jenkins error: "Process leaked file descriptors" when using the lscm command?


Jeffrey Cheng (1133) | asked Oct 01 '13, 7:13 p.m.
We have a Jenkins job that calls the lscm Windows batch script to log in to RTC. When running the Jenkins job however, we receive the error: "Process leaked file descriptors". This error also appears when running any other lscm command like logout and load. I've tried putting the lscm commands into a separate batch file but I get the same result. Any help would be appreciated. Thanks.

Comments
Donald Nong commented Oct 01 '13, 9:31 p.m.

Based on some comment about how this error gets generated, it seems the behavior is expected?
https://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build
Basically when you run lscm, it does spawn a process (the daemon). This may make Jenkins to believe it is a "problem", hence the error.
To verify this, you can try replace "lscm" with "scm". The difference between these two commands is mainly the daemon - no daemon for "scm".


Jeffrey Cheng commented Oct 02 '13, 3:24 p.m.

Using the "scm" command seems to work now, thanks. Are there any downsides to using "scm" rather than "lscm"? 


Geoffrey Clemm commented Oct 03 '13, 11:41 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

scm is slower, because it needs to reload all the eclipse libraries to execute the command (instead of sending the request to a running daemon, as is done by lscm).  But otherwise, the functionality is identical.

One answer



permanent link
Krzysztof Kaźmierczyk (7.4k34997) | answered Oct 02 '13, 3:06 a.m.
Hi Donald,
It seems to be Jenkins issue. I found similar issue here: http://stackoverflow.com/questions/17024441/process-leaked-file-descriptors-error-on-jenkins which refers to https://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build

Let us know if it helps.

Your answer


Register or to post your answer.