It's all about the answers!

Ask a question

Fields not updating when adding fields to custom forms

Sean Burke (3789136233) | asked Sep 20 '13, 2:16 p.m.
retagged Sep 20 '13, 5:55 p.m. by Dejan Custic (2855)
 What is frustrating me about custom forms in RTC is that if you add a new field to a section on the editor presentation it will show up for new tickets but not on existing tickets.  Has anybody else seen this?

Accepted answer

permanent link
Kevin Ramer (4.5k8180199) | answered Sep 20 '13, 3:01 p.m.
Probably everyone whose ever added new attributes.   I can see the pros of defering the attributes onto new work items only.  It keeps the RTC server from having to update potentially 10000s of work items, which may be of little benefit if only a fraction of those will ever be needed.   The database design of RTC isn't one large table for each work item and its attributes, rather one basic work item table and a dozen or so "extensions" tables.  Plus, work items are segregated by project area, so adding new attributes to what might be considered a single entity is probably not a desired effect.

It is possible to update old work items with the new attribute(s) by the "Synchronize Attributes" action.  In the RTC Eclipse there is a "show attributes usage" link above the Custom Attributes table for the work item.  Clicking it will check the project area and say "we're good." or "nn of mm work items do not have all attributes".   There is a Synchronize there.  Also, in the RTC Client work items can be synchronized piecemeal by right click on the Icon column in one or more rows and choosing the Synchronize Attributes.

Synchronizing also has the side - effect of touching the work item modification date.

Sean Burke selected this answer as the correct answer

Sean Burke commented Sep 20 '13, 5:30 p.m.

I can 't find how to do the synchronization .  I right click on the work items and get this menu option


2 other answers

permanent link
Dejan Custic (2855) | answered Sep 20 '13, 5:53 p.m.
Help about synchronize attributes is here

permanent link
Manoj Panda (39336662) | answered Sep 22 '13, 5:06 a.m.
Please mind about your cursor position, when you right click.

Your answer

Register or to post your answer.