It's all about the answers!

Ask a question

DB2 v9.7 causing error when installing RTC 4.0.3


Morten Madsen (3052842) | asked Aug 21 '13, 3:46 a.m.
edited Aug 21 '13, 4:36 a.m.
Hi,

I've tried several times to install RTC 4.0.3 with DB2 v9.7 both with FP 0 and FP4 and every time I click "test connection" (setting up the JTS DB) I get a "error in syntax of connection string" or something like that.

When I install DB2 v10.1 I get no errors and the installation continues successfully. Have anyone experienced this also, or can explain why this happens?

== EDIT ==
The full error msg is:

The server was unable to connect to the database because the database connection syntax is invalid. Verify the syntax in your teamserver.properties file. See the Jazz Team Server log for more information.ID CRJAZ2654E

My connection string is:

//localhost:50000/JTS:user=db2admin;password={password};
== EDIT ==

Thanks
/Morten.

2 answers



permanent link
Stephanie Bagot (2.1k512) | answered Aug 21 '13, 9:49 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
DB2 9.7 and future fix packs are supported. Have you tried to use a different name other than localhost?

Comments
Morten Madsen commented Aug 21 '13, 1:30 p.m.

Hmm, when I write the name of the server instead of localhost it just hangs... weird.

I'll try to re-download DB2 9.7 from the link from this site and try again.


Morten Madsen commented Aug 21 '13, 1:55 p.m.

It worked with the newly downloaded DB2 ESE v9.7 FP6..... hmmm, I really don't know whats going on here.

If you guys ever want me to supply a VMWare with the faulty settings or some more info just let me know.....


permanent link
Sandy Grewal (1.6k1123) | answered Aug 21 '13, 10:52 a.m.
JAZZ DEVELOPER
Morten,
The Syntax looks good, I have tried it many times sucsesfully with DB2 9.7

One thing to watch out is extra space before and after the String.



Comments
Morten Madsen commented Aug 21 '13, 1:31 p.m.

Yeah I think the syntax is fine, I just get a wrong error message from the system.

This test-install is on a VMWare though, but I've installed RTC at least 50 times over the last years, and only since 4.0.1 I've had trouble with 9.7.

10.1 always works fine.... hmmm.

Your answer


Register or to post your answer.