It's all about the answers!

Ask a question

Add OpenSocial Gadget

Brian Rodecap (5183) | asked Jan 14 '11, 12:15 a.m.
I am trying to add Sonar OpenSocial gadgets to my personal dashboard. When specifying the URL to the gadget, I get the following error...

org.apache.http.conn.ConnectTimeoutException: Connect to timed out

I've tried the Wikipedia example also, with the same result.

I suspect that the issue is with my proxy settings or outbound whitelist but cannot troubleshoot further. I would appreciate any thoughts or suggestions. Thanks!

7 answers

permanent link
Curtis d'Entremont (1.3k3) | answered Jan 14 '11, 12:21 p.m.
If you're able to open the gadget XML in your browser, then it sounds like a firewall issue, i.e. the firewall is blocking the request from your server to the gadget. You can confirm this by doing a wget on the server and see if it goes through.

permanent link
Brian Rodecap (5183) | answered Jan 14 '11, 7:02 p.m.
Good idea on testing using wget from the command line. I'm now certain that my proxy is the issue. Still, I cannot seem to find a way to set the proxy values in RTC.

I did find some instructions on setting up "" here...

...but that didn't seem to do the trick. Any thoughts on configuring the server to work with a proxy?

permanent link
Curtis d'Entremont (1.3k3) | answered Jan 17 '11, 11:16 a.m.
I may be wrong, but I don't think RTC supports this type of proxy. Is there any chance you can open up the firewall a bit so that these requests can go through?

permanent link
Benjamin Chodroff (8985231) | answered Jan 17 '11, 12:46 p.m.
I'm not positive if this will work, but give it a shot. Please let us know if it works -- we should definitely document this!

Create a new text file in a Jazz server folder, depending on application server type:

For Apache Tomcat: JazzInstallDir/server/tomcat/work/Catalina/localhost/jazz/eclipse/workspace/.metadata/

For IBM WebSphere Application Server: WASInstallDir/profiles/profile/temp/node/server1/jazz_war/jazz.war/eclipse/workspace/.metadata/

Paste the following contents to and edit it according to you proxy configuration:

# General proxy settings
# HTTP proxy settings
# proxyData/HTTP/host=<proxy>
# proxyData/HTTP/port=<proxy>
# proxyData/HTTP/hasAuth=false
# HTTPS proxy settings
# Hosts that will not use proxy
# nonProxiedHosts=<hostname1>

Restart the Jazz Team Server.

permanent link
Brian Rodecap (5183) | answered Jan 17 '11, 1:13 p.m.
No chance of opening up the firewall. Any chance a feature request could be opened to configure proxy settings?

permanent link
Brian Rodecap (5183) | answered Jan 17 '11, 1:26 p.m.
As mentioned in my previous post, the "" settings do not appear to work.

permanent link
Curtis d'Entremont (1.3k3) | answered Jan 18 '11, 2:32 p.m.
Here's the work item tracking the proxy configuration feature:

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.