It's all about the answers!

Ask a question

Modules are not showing in RDNG


K P (373) | asked Dec 16 '21, 1:22 a.m.
retagged Jan 19, 8:15 a.m. by Ian Barnard (1.2k613)

 Hi Team,


I am using RDNG version 6.0.6.1 and fetching the information using Postman tool.
I can able to fetch the project information By the reportable url as:
"https://<url>/rm/publish/resources?projectURI=_N3uEgIh-EeqZZ-_d9vVJJg"

I want to fetch the modules and artifacts details using reportable APIs but no luck. I have tried to fetch the modules in the particular project area by below URL:
but its showing blank page. 

Can you please help me to fetch the same

Thanks 


One answer



permanent link
Ian Barnard (1.2k613) | answered Dec 21 '21, 4:30 a.m.
JAZZ DEVELOPER
edited Dec 21 '21, 4:33 a.m.
You don't provide the iFix information: please ensure you are running the latest 6.0.6.1 iFix021.

"blank" do you mean you don't get any text or XML in the response body? What response code (200, 404, etc.) do you get?

That URL should return some XML as long as:
  • The projectURI is correct (but I get a 404 if I don't provide a correct project URI)
  • And:
    • EITHER the project is not configuration-management enabled
    • OR there is a default stream in the default component of the project (which is where data will be reported from if you don't specify the configuration). Otherwise provide the explicit URL for the configuration by adding query oslc_config.context=https://SERVER:PORT/rm/cm/stream/.... to the URL. You can get the configuration URL by going into the component and select any artifact then click the menu->Share Link to Artifact, the configuration is the last part of the URL shown. If you're providing the configuration URL you don't need to use the projectURI query parameter. An example of using the configuration URL is:
If either the projectURI or configuration is wrong I get a 404 response, not a "blank page"


Comments
Ralph Schoon commented Jan 19, 9:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Agree. Works for me in a not configuration management enabled pa. 

Your answer


Register or to post your answer.