It's all about the answers!

Ask a question

[closed] Rational ClearCase & ClearQuest Servers v8 and WAS v9 (non-Liberty) Compatibility


MK Skelton (25215) | asked Aug 07 '17, 11:25 a.m.
closed Aug 09 '17, 1:47 a.m. by Ralph Schoon (63.2k33646)

We currently run CC & CQ v8.0.1.9 with WAS (non-Liberty) v8.5.5.6. If we replace WAS v8.5.5.6 with WAS v9.0.0.4, will our IBM Rational ClearCase and ClearQuest Servers v8.0.1.9 be compatible? I'd like to know if anyone is running CC/CQv8 with WASv9.

IBM has relayed all the compatibility reports for each Rational component, but these only list the "minimum required" version of WAS. They do not list maximum versions, nor incompatible versions. Personally, I think these compatibility reports have not been updated as IBM admitted that they have not tested these two products together, yet. -I have asked them

So, if anyone is running CC/CQ Server(s) v8 with WAS v9 without any issues, I would like appreciate to know.

Thanks much

The question has been closed for the following reason: "Question is off-topic or not relevant" by rschoon Aug 09 '17, 1:47 a.m.

Accepted answer


permanent link
Donald Nong (14.5k414) | answered Aug 08 '17, 1:03 a.m.

Generally speaking, if a given platform has not been tested, it is then not supported. In other words, if you upgrade to WAS v9, you will put yourself into an unsupported environment.

MK Skelton selected this answer as the correct answer

Comments
MK Skelton commented Aug 08 '17, 9:03 a.m.

Hi Donald. True, but WebSphere v9 is an IBM product and it's my impression that they just haven't tested it as the focus is on RTC -not something like CC/CQv8 with an EoL on 4/30/2018.

I am hoping there is someone out there running CC/CQv8 with WASv9 (or has run it) who can inform me if they were compatible together.  Thanks for your reply.


Donald Nong commented Aug 09 '17, 12:14 a.m.

I saw the same question posted on dW Answers forum and a similar answer was given. I will reiterate my point - even if someone (let's say not from IBM) has been able to run CQ/CQ v8 with WAS v9, you are still at your own risk if you want to go down that path, as it will not be supported, officially, by IBM. If you encounter any issues in such environment, typically you will be asked to reproduce the issue in a "supported" environment first. You can argue that all IBM products should work together but it only holds true to a certain extent.


MK Skelton commented Aug 09 '17, 10:08 a.m.

A valid point, indeed. 

One other answer



permanent link
Geoffrey Clemm (30.1k33035) | answered Aug 08 '17, 12:39 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Aug 08 '17, 3:21 p.m.

 The best place to post CC/CQ questions would be at the ClearCase developerWorks forum:

I checked with the CC dev lead, and CC/CQ V8.x don't support WAS 9.  They are still at WAS 8 or 8.5.

This particular question is being discussed at:

The one CC/CQ topic area which would be appropriate for the jazz.net forum would be integrations between CC/CQ and RTC (such as the ClearCase Synchronizer and ClearCase Bridge).



Comments
MK Skelton commented Aug 08 '17, 1:45 p.m.

Thanks for the guidance, however the forum shows as "locked".  Please advise...


MK Skelton commented Aug 08 '17, 3:15 p.m. | edited Aug 08 '17, 3:18 p.m.

The "other" forum has a total (4) posts.


Geoffrey Clemm commented Aug 08 '17, 3:26 p.m. | edited Aug 08 '17, 3:26 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I've updated my answer above to point to the right forum (and I will send an appropriate message to the normally reliable individual who gave me those original pointers ... which doesn't really excuse my not having verified them before posting :-).



MK Skelton commented Aug 09 '17, 7:37 a.m. | edited Aug 09 '17, 7:39 a.m.

Thanks Geoffrey and no worries.  I have gone to this forum to post this question and it's already there since it was tagged with ClearCase.  Thank you, though :)