It's all about the answers!

Ask a question

Error 400 : Bad Request - when Saving a Query, but fetches the proper results on Run


Jazzuser user (4815) | asked May 15 '17, 3:39 a.m.

Hello Team,

We are facing an issue wherein, we are trying to create a simple RTC query.

However on save we get Error 400 : Bad Request.

On Run, we get the proper results.

What is the issue for the Error 400 : Bad Request.

Thanks.


Comments
1
Ian Wark commented May 16 '17, 11:48 p.m.

This may be a bug in the browser. Have you tried closing all browser windows and then clearing the browser cache and cookies? http://thewiseaffiliate.com/tutorials/fix-400-bad-request-error/

If that doesn't work..
Which version of RTC and which browser and browser version are you using? What happens if you try with the Eclipse client? Can you try another browser such as Chrome to see if you get the error? Does the error happen every time, or just sometimes? Do all users get the same problem or does it just happen for one user? I think we need more information to narrow down on possible causes.


Jazzuser user commented May 17 '17, 12:14 a.m.

Hello Ian,
Thanks for your reply. Actually user was trying to save the query with name containing underscore_ and hyphen- .

Eg: Test_this-query.

But I also tried with the same name, it worked for me. Is there something to do with the naming conventions for the query ?

Thanks

Be the first one to answer this question!


Register or to post your answer.