It's all about the answers!

Ask a question

Issue setting up RTC Plugin development environment with RTC 6.0.3


anup Gaur (139935) | asked Dec 16 '16, 6:14 p.m.
edited Dec 16 '16, 6:15 p.m.
 Hi,
I am getting this error while adding RTC SDK in the RTC PDE target platform setup. 
"You have selected a target with a newer version than your current Eclipse installation. This can cause unexpected behaviour in PDE. Please use a newer version of Eclipse."

I'm using RTC eclipse 4.2 client for RTC 6.0.3 with RTC server at 6.0.3. Also the SDK is from 6.0.3 downloads.
I have tried using Eclipse Kepler with RTC P2 install. I still get the same error. 

Also I see we have multiple versions of some of the SDK Plugins. 

I'm having a lot of unresolved bundle errors, I'm assuming they are because of some version conflicts, I have done this setup and development many times before in RTC 4x and 5x. I was successful with RTC 6.0.2 (I had to manually remove a few conflicting versions.) . But here we have many jars(more than 25) showing these duplicates.

Any suggestions are welcome.
Thanks in advance.


Accepted answer


permanent link
Ralph Schoon (57.1k23642) | answered Dec 17 '16, 7:09 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Dec 17 '16, 2:02 p.m.
Use Eclipse 4.4.2 with P2 install. See https://rsjazz.wordpress.com/2016/11/07/the-rtc-sdk-is-about-to-change-in-6-0-3/ for some information. I m working on updating the Extensions Workshop, but that will take a while. For the dplicates: I am not sure that is an issue, as I am able to set up the workshop.
anup Gaur selected this answer as the correct answer

Comments
anup Gaur commented Dec 17 '16, 9:17 a.m.

 Hi Ralph,

Thanks a ton for those pointers. Luna SR2 worked perfectly in one go. No hazzles.
The duplicates didn't bother this time.

Thanks again.


Ralph Schoon commented Mar 17 '17, 1:08 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Your answer


Register or to post your answer.