It's all about the answers!

Ask a question

Getting ServerVersionCheckExceptionYour even i use both client and server versions are SAME


Sudaraazhi Arivalagan (441227) | asked Jun 26 '15, 7:55 a.m.
edited Jun 26 '15, 7:56 a.m. by Ralph Schoon (59.4k23642)

Hi,

Anyone please suggest me why this error is thrown when i run my JAVA program using Plain Java APIs-4.0.6 on the server 4.0.6 same.

Error while executing doPost method of LoginPageHandler

com.ibm.team.repository.client.ServerVersionCheckExceptionYour client is version 4.0.0.1, and the server is version 4.0.6. These versions are not

compatible.com.ibm.team.repository.client.ServerVersionCheckException: Your client is version 4.0.0.1, and the server is version 4.0.6. These versions are not compatible.

at com.ibm.team.repository.client.internal.TeamRepository.checkServerVersionMatches(

TeamRepository.java:1722)

at com.ibm.team.repository.client.internal.TeamRepository.internalLogin(

TeamRepository.java:1472)

at com.ibm.team.repository.client.internal.TeamRepository.login(

TeamRepository.java:640)

at com.temenos.customreport.servlets.LoginPageHandlerServlet.doPost(

LoginPageHandlerServlet.java:77)

at javax.servlet.http.HttpServlet.service(

HttpServlet.java:643)

at javax.servlet.http.HttpServlet.service(

HttpServlet.java:723)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(

ApplicationFilterChain.java:290)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(

ApplicationFilterChain.java:206)

at org.apache.catalina.core.StandardWrapperValve.invoke(

StandardWrapperValve.java:233)

at org.apache.catalina.core.StandardContextValve.invoke(

StandardContextValve.java:191)

at org.apache.catalina.core.StandardHostValve.invoke(

StandardHostValve.java:127)

at org.apache.catalina.valves.ErrorReportValve.invoke(

ErrorReportValve.java:103)

at org.apache.catalina.core.StandardEngineValve.invoke(

StandardEngineValve.java:109)

at org.apache.catalina.connector.CoyoteAdapter.service(

CoyoteAdapter.java:293)

at org.apache.coyote.http11.Http11Processor.process(

Http11Processor.java:861)

at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(

Http11Protocol.java:606)

at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(

JIoEndpoint.java:489)

at java.lang.Thread.run(Unknown Source)


Comments
Ralph Schoon commented Jun 26 '15, 8:03 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have seen this and it was NOT because of the versions. Something deeper went wrong. I don't know what I did to get rid of it.

  • Can you check the Java Version that is used with your program? You should use the JRE that comes with RTC.
  • Can you check if the program runs if you run it from the RTC Eclipse Client that is set up for development?


Sudaraazhi Arivalagan commented Jun 26 '15, 8:51 a.m. | edited Apr 03 '19, 12:04 a.m.

I use compatible java version, also when i run/debug the program in RTC Client, getting the same error.

I think, problem is on some other place. But when i check the APIs from below,

at com.ibm.team.repository.client.internal.TeamRepository.checkServerVersionMatches(

TeamRepository.java:1722)

at com.ibm.team.repository.client.internal.TeamRepository.internalLogin(

TeamRepository.java:1472)

at com.ibm.team.repository.client.internal.TeamRepository.login(

TeamRepository.java:640)

 

Method "getClientVersionString()" from "com.ibm.team.repository.client.internal.TeamRepository" uses more APIs[] for referring the client version.

private String getClientVersionString()

{

Map compatibilityMap = ComponentConfigurationRegistry.INSTANCE.getClientCompatibilityMap();

String version = (String)compatibilityMap.get(

"com.ibm.team.rtc");

if(version == null)

version = (String)compatibilityMap.get(

"com.ibm.team.jazz.foundation");

return version;

}

com.ibm.team.jazz.foundation from below JAR file. Both Plain Java API Versions 4.0.0.1 and 4.0.6 contains the same JAR. 

com.ibm.team.foundation.client_1.1.1100.v20120901_0511.jar from RTC-Client-plainJavaLib-4.0.6.zip

com.ibm.team.foundation.client_1.1.1100.v20120901_0511.jar from RTC-Client-plainJavaLib-4.0.0.1.zip

I just doubt on this, problem found since the same JAR file shipped with RTC-Client-plainJavaLib-4.0.6. Make me clarified if it is wrong.

Thanks

Sudar


Sudaraazhi Arivalagan commented Jul 03 '15, 9:58 a.m.

Hi Palph,

Can you please help on this?

Am unable to login to my Web Report using RTC Plain Java APIs 4.0.6 version, even my web project takes JDK from RTC only.

Kindly suggest me something to resolve this issue.

Thanks

SUdar


Sudaraazhi Arivalagan commented Jul 21 '15, 2:05 a.m.

Hi Ralph,

Help me to sort out this issue.

Thanks.


Ralph Schoon commented Jul 21 '15, 2:18 a.m. | edited Jul 21 '15, 2:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I don't know what you are doing wrong here. There is also not really enough information to help. Check the log files of the server. Check that you use the Java version shipped with RTC and NOT some Oracle version. Check to use a JDK e.g. the one that ships with RTC as shown in https://rsjazz.wordpress.com/2015/04/07/the-day-the-jbe-stood-still/


Sudaraazhi Arivalagan commented Jul 21 '15, 2:47 a.m.

Ok Thanks :)

showing 5 of 6 show 1 more comments

Accepted answer


permanent link
Sudaraazhi Arivalagan (441227) | answered Dec 09 '15, 4:24 a.m.
Thanks Ralph ! I have fixed this issue by configuring buildpath to the right Libraries.
Ralph Schoon selected this answer as the correct answer

Your answer


Register or to post your answer.