It's all about the answers!

Ask a question

Unable to login to server from CLI


Shuchita Tripathi (30424890) | asked May 27 '14, 8:44 a.m.
edited May 27 '14, 9:18 a.m.

I am trying to login to a repository from scm command line. But it is throwing an error:

 
Problem running 'login':
Could not log in to <server>:9443/jazz as user <user>: CRJAZ2381E Cannot connect to the
repository at URL <server>:9443/jazz make sure that the server is running and available.
CRJAZ2381E Cannot connect to the repository at URL <server>:9443/jazz make sure that
the server is running and available.
An error has occurred. Kindly check the log for more details.

I am able to login to the web client successfully.

What could be the possible issue?

Also, where to find the logs for scm cli?


Comments
Krzysztof Kaźmierczyk commented May 27 '14, 9:32 a.m.

Hi Shuchuta,
I see that you are using /jazz context. Do you have exactly this context? What was server address you were attempting to log in?


Shuchita Tripathi commented May 27 '14, 11:48 a.m.

Yes the context is /jazz.

/ccm is not working. It is our official server so I cannot put the exact URL here.
I am trying to login to

I am able to login to the same url through web client and through eclipse client.
But I have to achieve this using CLI.

Accepted answer


permanent link
Karl Weinert (2.0k52736) | answered May 27 '14, 3:04 p.m.
JAZZ DEVELOPER
If you happen to have a proxy the cli needs to be configure to use it.

From https://jazz.net/library/article/325/

For the Jazz SCM command line and Visual Studio client, you can configure your terminal or command window to take advantage of a forward proxy by setting one of two environment variables prior to executing the command line.  

If using http, set the environment variable http_proxy to "http://<yourproxyhost>:<yourproxyport>".   
If using HTTPS, set the environment variable https_proxy to "https://<yourproxyhost>:<yourproxyport>".


What OS are you on and what version of RTC?

I don't think there will be much information related to this in the logs but they can be found in the following location.
Windows ..\Users\<user>\AppData\Local\jazz-scm\logs
Linux\Unix ~/.jazz-scm/logs

the eclipse .log file can be found in 
jazz-scm\scratch\0\.metadata

Note there may be multiple directories under scratch, you'll need to find the one associated with the current scm process.
So far I find the right one by trial and error or by deleting all the files in this directory and reproducing the problem again

Shuchita Tripathi selected this answer as the correct answer

Comments
Shuchita Tripathi commented May 28 '14, 2:00 a.m.

Hi Karl,

We are using a proxy and as suggested I did the required things.

But I am still getting the error. 2 errors are coming.

Sometimes the error is CRJAZ2384E, sometimes it is CRJAZ2381E

OS is Windows7

RTC version is 4.0.5

I have RTC client v4.0 and v4.0.6

I tired with both of them. Nothing is working.


Shuchita Tripathi commented May 28 '14, 3:31 a.m.

Hi Karl,

I finally tried with scm tools of RTC Eclipse version3.0 and it worked.

I have 2 doubts regarding it.

1. My RTC version is 4.0.5, why is it working only for scmtools v3.0?

2. I tried to login with userid in small letters <user1>.(it is actually the user ID). It got logged in successfully. However after this, for every command i got the error that repository is already logged in with <USER1>.

I followed this question and logged in with USER1 (all in caps) and now i am successfully able to execute every command.

https://jazz.net/forum/questions/63069/rtc-scm-cli-is-disconnected-from-daemon

Why is USER1 (in caps) able to login when my user id is in small letters?

Your answer


Register or to post your answer.