Rational solution for Collaborative Lifecycle Management (CLM) 6.0.3
IBM Internet of Things Continuous Engineering Solution (IoT CE) 6.0.3

Installation and Upgrade Notes

Note: The following changes in 6.0.3 are related to installation and upgrade procedures. Other changes and fixes are not included.

Installation notes

Upgrade notes


Installation notes

Description
All applications 6.0.3 applications require Java 7.1

Starting in 6.0.3, the CLM and IoT CE applications are built with and must run with Java 7.1:
CLM Server Monitoring was removed

CLM Server Monitoring, a performance monitoring utility included in versions 5.0.2 and later, was removed in 6.0.3. Version 6.0.3 includes a new, lightweight monitoring utility that uses industry-standard MBeans and that can be consumed by other application monitoring services. For more information about server performance and monitoring, see Plan Item 396673, Work Item 392897, and the Deployment wiki article about Known Expensive Scenarios.
Change and Configuration Management Smart card authentication can be configured

You can log in to the Rational Team Concert client by using a certificate file (.p12) or a smart card, which are more secure than logging in with a user name and password. For details, see Configuring certificate authentication in Rational Team Concert.
Databases After an AGENT_STACK_SZ error, increase the DB2 stack size

If you encounter the AGENT_STACK_SZ exception when you run the -deleteJFSResources command on a DB2 database, increase the stack size by running the following command in a DB2 command window:

db2 update dbm cfg using agent_stack_sz <value>

The default value on a 64-bit system is 1024 and can be set as high as 32768.
Oracle databases require a new JDBC driver

Because 6.0.3 requires Java 7.1, the requirement for the JDBC driver has also changed. If your Oracle database version is 12c, you must use the ojdbc7.jar file. If your Oracle database is 11g, you must use the ojdbc6.jar file. For details, see the Interactive installation guide and choose Oracle as your database provider.
SQL Server databases require a new JDBC driver

Because 6.0.3 requires Java 7.1, you must use the sqljdbc_4.1.jar file with your SQL Server database. For details, see the Interactive installation guide and choose SQL Server as your database provider.
Design Management Rational Software Architect Design Management was removed

Rational Software Architect Design Management is not included in version 6.0.3. As a result, the Rational Software Architect Design Management information was removed from the interactive guides in version 6.0.3.
Documentation All interactive guides are available from one page

In version 6.0.3, a single landing page is available where you can access all the interactive guides for installing, upgrading, and removing Collaborative Lifecycle Management (CLM) applications. For details, see Interactive installation, upgrade, and setup guides.
Jython scripts were corrected in the Interactive installation guide

Several Jython script command-line errors were corrected in version 6.0.3 of the Interactive installation guide.
New Interactive removal guide

Version 6.0.3 contains an interactive removal guide to help you uninstall packages and applications that you no longer need. For details, see Interactive removal guide.
Requirements Management To delete resources, the -deleteJFSResources command requires the force parameter

Because Rational DOORS Next Generation 6.0 changed how resources are unmapped from a configuration versus archived, the -deleteJFSResources command does not work in version 6.0 and later unless you use the force parameter. For details, see Repository tools command for permanently deleting resources.
Servers HTTP proxy servers require specific settings

If you have a proxy server in your environment, the Eclipse client uses the HTTP proxy setting and the HTTP proxy must support CONNECT for HTTPS connections.
Jazz Authorization Server requires extra server rename steps

If you use a Jazz Authorization Server in your environment, you must perform additional steps for a server rename operation. For complete instructions, see Server rename and the Jazz Authorization Server on the Deployment wiki.
Separate license servers must have a friend relationship with Jazz Team Server

If you use a separate Jazz Team Server as a license server, you must create a functional user and add a friend relationship between Jazz Team Server and the server that hosts the license server. For details, see Installing and managing floating client access license keys.

Upgrade notes

Description
All applications 6.0.3 applications require Java 7.1

Starting in 6.0.3, the CLM and IoT CE applications are built with and must run with Java 7.1:
CLM Server Monitoring was removed

CLM Server Monitoring, a performance monitoring utility included in versions 5.0.2 and later, was removed in 6.0.3. Version 6.0.3 includes a new, lightweight monitoring utility that uses industry-standard MBeans and that can be consumed by other application monitoring services. For more information about server performance and monitoring, see Plan Item 396673, Work Item 392897, and the Deployment wiki article about Known Expensive Scenarios.
The default heap size must be increased for large repositories

To avoid upgrade issues for larger repositories (greater than 100,000 artifacts), you must increase the default heap size. In repotools-app  (where app is the application that you are upgrading), increase the heap size to 8 GB, or up to a maximum of 24 GB. Increasing the heap size also improves upgrade performance by up to 20% for smaller repositories. For details, see the Interactive upgrade guide.
Change and Configuration Management Distributed SCM servers must be at the same version

If you have a distributed source-control management (SCM) environment, all servers must be at the same version level. Distributed SCM does not work if some servers are at an earlier version.
Design Management Rational Software Architect Design Management was removed

Rational Software Architect Design Management is not included in version 6.0.3. As a result, the Rational Software Architect Design Management information was removed from the interactive guides in version 6.0.3.
Documentation All interactive guides are available from one page

In version 6.0.3, a single landing page is available where you can access all the interactive guides for installing, upgrading, and removing Collaborative Lifecycle Management (CLM) applications. For details, see Interactive installation, upgrade, and setup guides.
Reporting Lifecycle Query Engine users must reindex data sources

If you use Lifecycle Query Engine for reporting, you must reindex your application data sources after you upgrade to version 6.0.3.

If you are upgrading from 6.0.1 or earlier versions to 6.0.3, you must reindex the following application data sources after the upgrade:

  • Rational DOORS Next Generation
  • Rational Team Concert
  • Rational Quality Manager
  • Design Management
  • Global Configuration Management

If you are upgrading from 6.0.2 to 6.0.3, you must reindex the following application data sources after the upgrade:

Requirements Management During an upgrade, the CRJAZ0554I timeout error might occur
 
During an upgrade, you might receive the following error, which indicates a timeout issue:

CRJAZ0554I Unable to get the necessary lock in 30000 milliseconds. 

Complete one or both of the following workarounds:
-Increase the timeout value to 60 seconds. In either the Advanced Properties or the teamserver.properties file, set the following property: com.ibm.team.repository.rdb.mediator.pool.wait=60000
-Rebuild the database indexes by running the -rebuildIndices command.

For details, see Work Item 404381 and Repository tools command to rebuild database indexes.

Graphical artifact editor browser add-on was removed

The graphical artifact editor browser add-on was removed from the RM application in version 6.0.3. Current internet browsers no longer support NPAPI plug-ins, and the browser add-on is no longer supported.

Graphical artifacts that were created with the browser add-on are now read-only. If you need to edit existing graphical artifacts that were created with the browser, do not upgrade to 6.0.3.

To create new graphical artifacts in the RM application, use the newer HTML-based diagram editor. To assist the move to the new diagram editor feature, a migration utility is planned for a future release. For details, see Plan Item 105992.
Version 5 baselines must be restored

If you upgrade the Requirements Management application from any version 5 release to version 6.0.3, you must restore the baselines. If you upgrade from any version 6 release, you do not have to restore baselines. The Interactive upgrade guide dynamically shows this step if you are upgrading from a version 5 release.

© Copyright IBM Corporation 2016  |  Contact  |  Privacy Policy  |  Terms of Use