RegisterLog In to Jazz.net dW

System Requirements for Rational Team Concert 3.0.1.x, Rational Quality Manager 3.0.1.x, Rational Requirements Composer 3.0.1.x (and Jazz Foundation 3.0.1.x)

Updates for 3.0.1.1 appear as (new for 3.0.1.1)
Updates for 3.0.1.2 appear as (new for 3.0.1.2)
Updates for 3.0.1.3 appear as (new for 3.0.1.3)
Updates for 3.0.1.6 appear as (new for 3.0.1.6)

Related Articles

Collaborative Lifecycle Management 3.0.1 Sizing Guide

Please Note: The platforms listed below are the starting point for 3.0.1.x support and unless otherwise indicated support includes this level and all future OS fixpacks. 

Server

Operating Systems

  • Windows Server 2008 R2 x86-64
  • Windows Server 2008 SP2 x86-32, x86-64
  • Windows Server 2003 SP2 x86-32, x86-64
  • Red Hat Enterprise Linux Server 6 x86-32, x86-64, System z and Power (new for 3.0.1.1)
  • Red Hat Enterprise Linux Server 5 Update 4 x86-32, x86-64, System z and Power
  • SUSE Linux Enterprise Server 11 SP1 x86-32, x86-64, System z and Power (new for 3.0.1.2)
  • SUSE Linux Enterprise Server 10 SP2 x86-32, x86-64, System z and Power
  • AIX 7.1 p-Series (new for 3.0.1.1)
  • AIX 6.1 p-Series
  • AIX 6.1 p-Series
  • AIX 5.3 p-Series
  • IBM z/OS v1.9 and later
  • IBM i 7.1 for Power
  • IBM i 6.1 for Power
  • IBM i5/OS V5R4
  • Solaris 10 SPARC
  • VMWare vSphere 4.0 x86-32, x86-64 (w/supported Windows & Linux OSs)
  • VMWare ESX and ESXi 4.0 and 4.1 x86-32, x86-64 (w/supported Windows & Linux OSs) (new for 3.0.1.1)
  • VMWare ESX and ESXi (new for 3.0.1.1) 3.5 x86-32, x86-64 (w/supported Windows & Linux OSs)
  • VMWare ESX 3.5 x86-32, x86-64 (w/supported Windows & Linux OSs)
  • Red Hat Enterprise Virtualization Hypervisor (RHEV-H) / KVM 83-105 (IBM Cloud platform)

Server Operating System Notes

  • The RRC Converter application will not run on IBM AIX, Linux for Power, Solaris or IBM i systems. The server-side converter.war, needed to view graphical artifacts, must be deployed on a supported Windows, x86 Linux or zLinux platform. If your RRC installation is on a platform not currently supported by the converter application, this document describes the delegated converter configuration option: Rational Requirements Composer Converter Application Installation.

Rational Team Concert promotion and deployment support for z/OS require the REXX runtime or REXX alternate libraries (REXX.**.SEAGLPA, or REXX.**.SEAGALT). If you do not have either the REXX Library or the REXX Alternate Library installed, you can install the REXX Alternate Library to fulfill the REXX Library requirement. The REXX Alternate Library is shipped as part of the z/OS operating system beginning with release 1.9. The Alternate Library is also available as a free download from http://www.ibm.com/support/entry/portal/.

The Rational Team Concert ISPF client requires cURL, an open source tool supplied through IBM Ported Tools Supplementary Toolkit for z/OS. Information on IBM Ported Tools can be found at http://www.ibm.com/systems/z/os/zos/features/unix/ported/. If you already have IBM Ported Tools installed, cURL for z/OS is available by ordering the PTF for APAR OA22944. Information on the Supplementary Toolkit for z/OS can be found at http://www.ibm.com/systems/z/os/zos/features/unix/ported/suptlk/index.html.

Rational Team Concert uses the ISPF Gateway component of ISPF to access z/OS files and to perform work item-based packaging and deployment. For the ISPF Gateway component to function correctly, you must install the PTF for APAR OA35689 or APAR OA38035 (z/OS 1.9). For the supported ISPF releases, these PTFs are:

  • z/OS 1.9: UA63763
  • z/OS 1.10: UA59950
  • z/OS 1.11: UA59951
  • z/OS 1.12: UA59951
If you do not install the appropriate PTF, you might encounter problems with ISPF Gateway usage.

The following PTFs are required on IBM i:

IBM i 7.1:

  • Group Security: SF99708
  • Technology Refresh: SF99707
  • DB2 for IBM i: SF99701
  • IBM HTTP Server for i: SF99368
  • Java: SF99572
  • WebSphere Application Server V7.0: SF99324 (7.0.0.13)
  • WebSphere Application Server V6.1: SF99323 (6.1.0.31)

On IBM i 6.1:

  • Group Security: SF99608
  • DB2 for IBM i: SF99601
  • Java: SF99562
  • TCP/IP Group PTF: SF99354
  • WebSphere Application Server V7.0: SF99324 (7.0.0.13)
  • WebSphere Application Server V6.1: SF99323 (6.1.0.31)

On IBM i5/OS V5R4:

  • Group Security: SF99538
  • DB2 for IBM i: SF99504
  • Java Group PTF: SF99291
  • TCP/IP Group PTF: SF99315
  • WebSphere Application Server V7.0: SF99324 (7.0.0.13)
  • WebSphere Application Server V6.1: SF99323 (6.1.0.31)

For the latest IBM i Group PTFs, go to http://www-912.ibm.com/s_dir/sline003.nsf/GroupPTFs?OpenView&view=GroupPTFs.

Memory Requirements

  • We strongly recommend a 64-bit operating system and a minimum of 4 GB of server memory for running the Jazz Team Server and all three applications (Change and Configuration Management, Quality Management, Requirements Management) on one server for small deployments. Larger deployments or loads may require significantly more memory.
  • The Java virtual machine max heap memory setting is configured to -Xmx4000M for 64-bit platforms and -Xmx1200M for 32-bit platforms. For 64-bit deployments where less memory is available, it is possible - although discouraged - to configure the Java virtual machine memory size to a lower setting (e.g. -Xmx1200M to match the 32-bit setup). For the Tomcat installation, the server.startup script file to edit is located under JazzInstallDir/server/, and controlled by the line: set JAVA_OPTS=%JAVA_OPTS% -Xmx4000M. For a WebSphere Application Server installation, please consult the WebSphere Administrative Console, and modify Servers>Application Servers>server1>Java and Process Management>Process Definition>Java Virtual Machine>Maximum Heap Size.
  • Memory requirements can be reduced by running a subset of applications such as just CCM to support RTC-only functionality. Additionally if applications and/or the Jazz Team Server are running on different machines, memory requirements for specific machines may be reduced.

Application Servers

  • Apache Tomcat 5.5.30 [Bundled with 3.0.1.1-3.0.1.5] (3.0.1 bundled 5.5.30) (3.0.1.1 upgraded to 5.5.33), (3.0.1.3 upgraded to 5.5.35)]
  • Apache Tomcat 7.0.32 New - Bundled with CLM 3.0.1.6 - includes critical security fixes]
  • WebSphere Application Server 7.0 Fixpack 9 [7.0 Bundled and updates automatically to fixpacks]
  • WebSphere Application Server 6.1 Fixpack 27
  • WebSphere Application Server OEM Edition for z/OS v7.0 Fixpack 15 [Bundled]
  • WebSphere Application Server OEM Edition for z/OS v6.1
  • WebSphere Application Server for z/OS v7.0
  • WebSphere Application Server for z/OS v6.1
Application Server Notes

Databases

  • IBM Derby SDK 10.5 [10.5.3.2.1073208 Bundled] (for small teams of 10 users or less)
  • DB2 Enterprise Server Editions v9.5 FP 3a, v9.7 [9.7 Enterprise Bundled for 64-bit platforms]
  • DB2 Workgroup Server Editions v9.5 FP 3a, v9.7 [9.7 Workgroup Bundled for 32-bit Windows and Linux]
  • DB2 Express Server Editions v9.5, v9.7 FP3a (Windows & Linux only) (for small teams of 50 developers or less)
  • DB2 for IBM i5/OS V5R4, IBM i 6.1, and IBM i 7.1 (IBM i only)
  • DB2 for z/OS v10.1 (with PTF UK77844)
  • DB2 for z/OS v9.1
  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2005 SP3, 2008 SP1
  • Microsoft SQL Server Express 2005 SP3, 2008 SP1 (for small teams of 50 developers or less)
  • Oracle Database 11g Standard and Enterprise Editions Release 2 (requires 11.2.0.2.0 or later OJDBC driver; not supported for z/OS or IBM i)
  • Oracle Database 10g (10.2.0.1) Standard and Enterprise Editions Release 2 (not supported for z/OS or IBM i)

Token License Servers

  • Rational License Server 8.1.1 [Bundled]

Eclipse

  • Eclipse SDK 3.5.2 (Eclipse Runtime, Equinox and EMF) [Bundled]

HTTP Reverse Proxy Support

  • IBM HTTP Server 7.0 Fixpack 9
  • IBM HTTP Server 6.1 Fixpack 27
    • Non-secure (no HTTPS) only for these supported versions:
      • Apache 2.2.9 on SUSE Linux Enterprise Server (SLES) 10.0
      • Apache 2.2.10 on SUSE Linux Enterprise Server (SLES) 10.0
      • Apache 2.2.10 on Red Hat Enterprise Linux 5.0
  • Squid 3.0 for caching (see Using content caching proxies for Jazz Source Control)

Java Runtime Environment

  • IBM Java SDK 6.0 SR15 for 3.0.1.6 iFix1 (Bundled)
  • IBM Java SDK 6.0 SR13 is 3.0.1.6 (Bundled)
  • IBM Java SDK 5.0 SR11 for 3.0.1 - 3.0.1.5 (Bundled)
  • Sun Java JRE 1.6 Update 17
  • Sun Java JRE 1.5 Update 16

Identity Management

  • IBM Tivoli Directory Server 6.0
  • IBM Resource Access Control Facility (RACF) V1R9 + (for System z)
  • Microsoft Active Directory 2003 SP2

Report Customization

  • Rational Reporting for Development Intelligence 1.0.2.1 (RRDI updated to 1.0.2.1 for 3.0.1.2) [Bundled]

Client

Reminder: The platforms listed below are the starting point for 3.0.1.x support and unless otherwise indicated support includes this level and all future OS fixpacks. 

Operating Systems

  • Windows 7 Professional, Enterprise & Ultimate x86-32, x86-64 (in 32-bit mode)
  • Windows Vista SP1 Business, Enterprise & Ultimate x86-32, x86-64 (in 32-bit mode)
  • Windows XP Professional SP2 x86-32, x86-64 (in 32-bit mode)
  • Red Hat Enterprise Linux Desktop 5.0 Update 4 x86-32, x86-64 (in 32-bit mode)
  • SUSE Linux Enterprise Desktop 11 SP1 x86-32, x86-64 (in 32-bit mode) (new for 3.0.1.2)
  • SUSE Linux Enterprise Desktop 10.0 SP2 x86-32, x86-64 (in 32-bit mode)
  • Ubuntu LTS Desktop 10.04 x86-32, x86-64 (in 32-bit mode) <this LTS version only> Note xlrunner workaround: WI 133464
RTC Client for zLinux (All new for 3.0.1.1)
  • Red Hat Enterprise Linux Server 5.0 Update 4 x86-64  System z
  • SUSE Linux Enterprise Server 11 SP1  x86-64 System z (new for 3.0.1.2)
  • SUSE Linux Enterprise Server 10.0 SP2 x86-64 System z
Community Support Only (via Jazz.net) -  no Installation Manager install, no globalization
  • Mac OS X 10.5 and above x86-32, x86-64 (with Firefox 3.6 Browser only)

Client Operating System Notes

  • Smart Card is supported for all CLM Windows Platforms
  • The server component for RRC Visual Graphic Editors, is only supported on Windows and Linux platforms
  • The Build System Toolkit (Client) is supported on all Server Platforms
  • The SCM Command-Line Tool is supported on all Server Platforms except for IBM/i and z/OS. For z/OS it has support for the hiearchical file system

Browsers

  • Firefox 17 Extended Support Release (ESR) New support for 3.0.1.6
  • Firefox 10 Extended Support Release (ESR) (FF 10 was new for 3.0.1.3 but is now out of service from Mozilla)
  • Firefox 3.6 (FF 3.6 is now out of service from Mozilla)
  • Internet Explorer 8 Please see known issues and workarounds for IE8 in this Article
  • Internet Explorer 7
  • Macromedia Flash Player 8 (version 8.0.22.0, codenamed Maelstrom) (August 2005) for graphical view in Work Item Statistics dashboard viewlet

Network Infrastructure

  • IPv6
  • IPv4

Eclipse

  • Eclipse SDK 3.6, 3.6.1, 3.6.2
  • Eclipse SDK 3.5.2 [Bundled]

Additional IDEs

  • Microsoft Visual Studio 2012 with .NET 4.5 New for CLM 3.0.1.5
  • Microsoft Visual Studio 2010 with .NET 4.0
  • Microsoft Visual Studio 2008 SP1 with .NET 3.5 SP1
  • Microsoft Visual Studio 2005 SP1 with .NET 3.5 SP1
  • Rational Developer for Power Systems Software V8.0 (required to access additional IBM I functionality)

Java Runtime Environment

  • IBM Java SDK 6.0 SR15 for 3.0.1.6 iFix1 (Bundled)
  • IBM Java SDK 6.0 SR13 is 3.0.1.6 (Bundled)
  • IBM Java SDK 5.0 SR11 for 3.0.1 - 3.0.1.5 (Bundled)
  • Sun Java JRE 1.6 Update 17
  • Sun Java JRE 1.5 Update 16

Additional requirements for Requirements Management

  • The client-side RRC Browser Add-Ons, needed if you plan to edit graphical artifacts, requires Mozilla FireFox (FF) 3.6 (recommended) or Microsoft Internet Explorer version 7 or 8 and can only run on supported Windows platforms.
  • The server-side converter.war, needed to view graphical artifacts, must be deployed on a supported Windows, x86 Linux or zLinux platform. If your RRC installation is on a platform not currently supported by the converter application, the following document describes the delegated converter configuration option: Rational Requirements Composer Converter Application Installation.

Additional requirements for Quality Management

Test Tool Adapter Integrations

  • Rational Functional Tester 8.2
  • Rational Performance Tester 8.2
  • Rational Service Tester 8.2
  • Rational AppScan Enterprise Edition 8.0
  • Rational Robot 7.0.3.4
  • Rational Test RT 7.5.0.4

Test Tool Migrations

  • Rational Manual Tester 7.0.1, 7.0.1.x
  • Rational ClearQuest (CQTM) 7.0.1, 7.0.1.x, 7.1, 7.1.x
  • Rational TestManager 2003.06.15, 2003.06.16, 7.0, 7.0.1, 7.0.2

Requirements Integrations

  • Rational RequisitePro 7.1.1.5 and newer or 7.1.2.2 and newer (Requires RequisiteWeb)
  • Rational DOORS 9.2.0.1 and newer
  • Rational Requirements Composer 2.0.0.x, 3.0.1

Change Management Integrations

  • Rational Team Concert 2.0, 2.0.0.1, 2.0.0.2, 3.0, 3.0.1
  • Rational ClearQuest 7.1.1 and newer using direct OSLC connection
  • Rational Change 5.2.0.1 (Integrated using OSLC 1.0)

Test Lab Management Integrations

  • Rational Build Forge 7.0.0.2 ifix2, 7.1, 7.1.1, 7.1.2
  • Tivoli Provisioning Manager 5.1.1, 7.1.1
  • Tivoli Application Dependency Manager 7.1.0 (7.1.2 not supported)
  • Software Testing Automation Framework (STAF) 3.3.x
  • Software Testing Automation Framework Execution Engine (STAX) 3.3.x

For Team Concert and additional integrations with 3.0.1 products please see the SWG Clearinghouse


Feedback
Was this information helpful? Yes No 27 people rated this as helpful.