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Lab 3 Configuring Work Items

This lab will guide you through the definition of a new Work Item Type in Rational Team Concert. You 
will define the basic structure and information for this new type. The lab will focus on how these items 
can be described in your process using Rational Method Composer, and how to realize this 
information description in a Rational Team Concert process template.

Lab Scenario

The team working in “Nifty Application 1.0” would like to schedule and track results of meetings using 
Rational Team Concert work items.

In this lab you will:

• Configure an existing process to describe how meetings will be managed.

• Create a new work item type from the process description

• Use the work item type in a work item template.

• Elaborate the work item type with new attribute types and reuse existing attributes

• Create and understand work item's workflows, their description in the process, and how to link  
workflows with work items.

• Adjust the presentation of your work items.

Lessons Learned:

• Describe workflows in your process

• Communicate process description changes to Rational Team Concert members who will adopt 
them

• Create work item types and customize all the basic elements involved in their definition
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3.1 Update the process description

You are going to add content to your tailored process in RMC. Customizing the process description for 
your team organization process in Rational Method Composer is a task performed by the Process 
Engineer role.

Reload the RMC Workspace Library

If you shut down RMC, you will need to re-load the RMC 
workspace library when you restart. 

Select File>Open>Method Library. In the Open Method
Library window, select Open method library from 
workspace, and then select Finish.

The process customization tasks that you will perform are:

– Create a new Work Item Type that represents the workflow for meetings.

Process customization for the lab

The main purpose of this workshop is to guide you 
through process customization in Rational Team Concert
and how this can be driven by the enactment of your 
enterprise process description performed in Rational 
Method Composer.

It is for this reason that we provide you with Rational 
Method Composer method plugins with the basic 
process content we will need for the different lab 
scenarios; to put you in the context for the RTC process 
customization exercise. In your real environment you, as 
process engineer, begin by creating this process 
description in RMC.

3.1.1 Complete the process description of the new Work Item Type

The Nifty team will use the new work item type to manage meetings. You will complete the description of
this work item type in your process.

__1. Document the work item type in RMC 

__a. Switch to RMC. In the Authoring perspective, in the Library view, navigate to practice >
mgmt > scrum > extend-acme > Method Content > Content Packages > acme
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__b. Right click and select New > Work item type

User-defined types

The “Meeting” work item type is not a standard type in RMC.
This type has been added to this library using the user-defined
types feature.

To  see  how this  type  was  added,  click  File  >  Create  UDT
Definition.  View the XML then close the window.  For more
information,  refer  to  RMC  online  help  and  the  RMC  and
Practices community on DeveloperWorks.

__c. Enter:

__i. Presentation name: Meeting

__ii. Name: meeting (if preferences set correctly, this will be automatically set.

__d. Add a predefined state diagram to the main description

__i. Click the rich text editor icon to the left of Main Description.

__ii. Click the Add image link

__iii. Browse to add resources > meeting_states.jpg
(Full path:  root\PEW\Workspaces\Lab1\practice.mgmt.scrum.extend-
acme\guidances\practices\resources\meeting_states.jpg)

__iv. Click OK 

__v. Add additional text as desired.

__vi. Click Save.

Lab 3 DCB-2008: Process Customization, Reuse and Reconciliation in IBM CLM Products Page 3



IBM Software

What does this description mean?

In this lab you will create a Work Item Type in Rational Team
Concert representing this RMC element.

The text and diagram in the description of the RMC element
gives information about the main actions taken by the person
responsible  for  a  work  item  of  this  type.  This  is  the source
information you use to define the RTC workflow of  the work
item type later.

__2. Open the Pending Changes view. Right-click on the Process Extensions > Outgoing folder and 
select Check in and deliver. (If you are prompted to create a work item, create one).

__3. Use the new work item type in a work item template

__a. In the library view, open practice > mgmt > scrum > extend-acme > method content > 
content packages > acme > tasks > share_product_vision.acme
(created in Lab 2)

__b. Click on the Relationships tab (it may be elided, in which case you need to click the 
Show List icon to the right of the tabs).

__c. Scroll down to the Of Type relationship section. 

__d. Click Add 

__e. Type meeting to filter the selections.

__f. Click meeting.  Click OK.  Click Save.

This change affects every place the task is used, including the Project Initiation 
workflow/capability pattern (as shown below in the Acme process website).
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Capability patterns and work item templates

Whenever you want to describe a flow of tasks in RMC, 
you use work breakdown structures, called Capability 
Patterns (for partial processes) or Delivery Processes 
(for complete process workflows).
These work breakdown structures can be used to create 
work item templates in RTC.  When you create work 
items from such a work item template, you get:

– a work item for each task
– a link from each work item to the task in the 

RMC website from which it was created.

3.1.2 Publish the new process description

Now you want to publish this new version of your process to make it available to all the teams working 
with Acme Process.

__1. Publish the changes to the server.

__a. Under the Configuration menu, select Publish...

__b. Make sure Use publish options stored in the method configuration is checked and Don't 
review publish options is selected (this will assure that the process will publish with the 
options defined in the configuration). Select Next.

__c. Select acmeprocess in Method configuration and Next.

__d. Make sure the option Java EE web application is selected with the following options, 
then select Finish. (Select OK when prompted to overwrite)

__i. Directory: root/PEW/Downloads/acmeprocess

__ii. Web application name: acmeprocess3

__iii. Package format: WAR

__iv. Leave other settings as defaulted.

__e. Make sure the Publishing Report shows no errors then close the window.

__f. Move the acmeprocess3.war file from root/PEW/Downloads/acmeprocess to 
root/PEW/IBM/JazzTeamServer/server/tomcat/webapps; (Replace any existing 
acmeprocess.war file).

__2. Verify the changes

__a. In your browser navigate to https://clm.process.ws/acmeprocess.

__b. In the treeview, select Rational Team Concert > Work item types > Meeting 
and review the information.
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3.2 Customize the process in RTC

We will now update the Nifty Application Project area to match the changes in the process description.

__1. Create the Work Item type

__a. Go back to RMC and switch to the Team Process perspective

__b. Choose acmeprocess in the Method drop-down field

__c. On the Team Process Navigator, select the option to display the treeview in Navigation 
mode.

__d. In the treebrowser, right click Acme Process > Rational Team Concert > Work Item 
Types > Meeting 

__e. Click Create Jazz Work Item Type

__f. Choose the following values and click Finish:

__i. Project Area: Nifty Application Project (within the SoftwareDev repository)

(Note: We are creating this in a “real” project to try it out.  Later we will harvest 
this into ccm-pew and distribute it as a template to be used by new projects.)

__ii. Context root: /acmeprocess3 

(Reminder: context root is the URL where process guidance is published).

__iii. Workflow: Defect Workflow (leaving as default – we can update this later in RTC)

Administrative override?

Don't be concerned if you see messages that say 
“Permission denied” followed by “Administrative 
override”.   Creating work item types and templates from 
RMC requires administrative privileges.  RTC produces 
these messages as part of the interface.

__2. Replace the work item template for Project Initiation

__a. Still in the Team Process Perspective, right click on Acme Process > Project initiation.
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__b. Click Create Jazz Work Item Template.

__c. Choose the following values and click Finish:

__i. Project Area: Nifty Application Project (within the softwareDev repository)

__ii. Context root: /acmeprocess3 

__3. Make further changes to the work item type using RTC

__a. In the browser, you should be in the Nifty Application Project area.
Click the wheel icon at the top right , and click Manage this Project Area.

__b. Click the Work items tab on the left.

__c. Under Choose the Work Item Type to edit, click Meeting.
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What is the deal with the Ids?

When customizing your process you will have to define 
IDs for different items: work item types, attribute types, 
presentations, …

It is a good practice to define a naming convention within 
your enterprise. The elements of process customizations
should follow this naming convention so the RTC 
process is consistent in your company, and it will ease 
the development leveraging these IDs: you will be able to
quickly locate process customizations within the whole 
process. In addition, as removing elements is an 
operation to avoid for its potential impact, it is  a good 
practice to modify the ID of the elements you want to 
deprecate with a certain pattern instead of just deleting 
the elements.

What is a Work Item Type Category?

Work Item Type Categories define a common workflow 
and custom attributes shared by all the work item types 
that belong to it.

As our new work item type will have its own workflow, we
need to create a new category along with the type.

__d. Click the Icon: Edit button and select an icon, such as  adoption.gif
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__e. Save your changes.

__4. Now we will add some custom attributes. 

__a. Navigate to the Attributes section of the page.

__b. Select Add …

__c. Enter the following values:

__i. Name: Meeting minutes

__ii. ID: com.acme.workitem.attribute.minutes

__iii. Type: Large HTML

__iv. Select OK.

__d. Add another attribute: 

__i. Name: Affected Departments

__ii. ID: com.acme.workitem.attribute.affdepts

__iii. Type: String List

__iv. Select OK.

__5. Reuse existing attribute:

__a. Select Add …

__b. Check Reuse Existing Attribute and select “Affected teams” from the drop-down list

__c. Select OK.

Re-using attributes

This reuse feature allows you to leverage attribute 
customizations from other  work item type categories, 
easing maintenance of your process.

__6. Define enumeration for the formality attribute:

__a. Click the Enumerations tab

__b. Select the Add... button located below Choose the Enumeration to edit

__c. Enter the following values and select OK:
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__i. Name: Formality

__ii. com.acme.workitem.enum.formality

__iii. Process Specification: CHECKED

__d. Select Add... at the  Literals section, and enter the following values for the “Name” 
attribute of each literal value, you can leave the “External Value” field empty: (assign 
icons as you wish)

– Low

– High 

__i. Select the value Low for Default Literal and Unassigned Literal

__ii. Click Save

__e. Create the attributes for the enumeration:

__i. Click Types and Attributes tab

__ii. Make sure Meeting Work Item Type is selected.

__iii. Navigate to the Attributes section of the page.

__iv. Select Add …

__v. Enter the following values, then select OK:

__a. Name: Formality

__b. com.acme.workitem.attribute.formality

__c. Type: Formality
Do not select Formality (enumeration list).
Formality let's you assign just one formality value for a meeting.
Formality (enumeration list) lets you assign multiple formality values.

Adding attributes to existing work items

If you add new attributes to work item types that already 
have work items created, you have to Synchronize the 
attributes to be able to use the new attribute in that 
existing work items.

The article Cool “Hidden” Features in Rational Team 
Concert: Part 2  explains this feature. Part 3 contains 
links to the other articles (attributes synchronization is 
located in part 2 of the series)
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__7. Define the workflow: the Process Engineer described the workflow in RMC. Now you will create 
a work item workflow matching that description.

__a. Select the Workflows tab.

__b. Select Add... next to the Choose the workflow to edit field.

__c. Enter the following values and then select OK:

__i. Name: Meeting Workflow

__ii. ID: meetingWorkflow

__d. Navigate down to the States section. Click Add... button and create the states with the 
following information: (assign icons as you will).

Name Group Show Resolution

Planned Open Unchecked

Scheduled Open Unchecked

Minuted Open Unchecked

Actions addressed Open Unchecked

Closed Closed Unchecked

Canceled Closed Checked

What are the State Groups?

The State Groups help you categorize states and 
resolutions that relate to each other.

You can create new state groups and associate them to 
the default group categories: Open, In-Progress, Closed.
These grouping of states and resolutions are very useful 
for building queries / reports, and when you extend 
Rational Team Concert and want to interact with Work 
Items states.

In addition, these categories are associated with OSLC 
state groups, thus providing a way of isolating the 
detailed knowledge of your actual defined workflow for 
integration with other systems via OSLC.

__e. Create the actions that cause the state transitions: in the Actions section of the page, 
perform the following:

__i. Click Add 

__ii. Enter Plan as the name.  For Target state click Planned. Select OK.
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__iii. Repeat steps i – ii, with the rest of these actions.

Action name Target state

Schedule Scheduled

Complete minutes Minuted

Close actions Actions addressed

Close Closed

Cancel Canceled

__f. Describe the legal transitions (from state to state): navigate to the Transitions section of 
the page and perform the following changes:

__i. In the combination From “Planned” To “Scheduled”, click the dropdown and 
select Schedule.

__ii. Repeat with the rest of the transitions until you build the following transition table 
(which maps to the flow you described in Rational Method Composer earlier in 
this lab):

__g. Define the start action: 

__i. Select the dropdown next to Start Action and click Plan.

Resolve and Reopen actions

You may wonder why we left these fields blank.
Our defined workflow has two different possible end 
states depending on the path: we didn't consider a 
unique and global resolve action. 

In addition, we defined a reopen type of action (“Plan”) 
for each of the states.  We could go back into RMC and 
correct the diagram, but often it is best to just show the 
normal flow, and not the less usual transitions, such as 
reopening/replanning.
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__h. Define the resolutions: you want to further explain the possible reasons for cancelling a 
meeting.

__i. Navigate to the Resolutions section.

__ii. Click Add...

__iii. Enter No longer required as the name. Select OK.

__iv. Repeat the steps to include a resolution called Duplicate.

__i. Navigate back to the Actions section of the page and configure resolutions:

__i. In the row for the Cancel action, click on  Click to select Resolutions.

__ii. Click  Add All.  Click OK. 

__j. Save your changes.

__k. Associate the workflow to the work item:

__i. Navigate to the Types and Attributes tab.

__ii. Choose Meeting under Choose the Work Item Type to edit.

__iii. In the Workflow dropdown, select Meeting Workflow.

__iv. Save your changes.

__8. Customize the presentation for the work item
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Work Item editor presentation structure:

The work item editor presentation is structured in tabs. 
Each tab contains slots which are the containers for the 
actual presentation of information. This information can 
be “attribute-based” or “non-attribute” based (like the 
presentation for the attachments of a work item).

How information is placed in a tab, and the organization 
of the slots, is based on the concept of a layout. There 
are different types of layouts depending the information 
you want to place and how you want to organize it. For 
more information see Work item editor presentations.

The presentation editor is based on the concept of reuse.
The definition of tabs and slots can be shared among 
different work item editor presentations. If you modify a 
shared configuration it will apply to all the presentations 
that make use of it. As an alternative, you have the 
option of creating new presentations (whether tabs or 
layouts), or duplicating an existing presentation and 
customize for your particular needs.

__a. For ease of use, you will create a presentation based on an existing one, customizing it 
to hold the required attributes.

__i. Back in RMC, change the perspective to Work Items.
(This is a Jazz/RTC perspective that happens to also be available in RMC).

__ii. Click on Manage Connected Project Areas

__iii. Select the existing repository connection then click Next 

__iv. Select all project areas then click Finish.

__v. Change the view to Team Artifacts.

__vi. Right-click Nifty Application Project [SoftwareDev] and click Open.

__vii. Click the Process Configuration Tab.

__viii. Click Project Configuration > Configuration Data > Work items > Editor 
presentations.
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__ix. Make sure in the Choose editor presentation to edit box the 
com.ibm.team.workitem.editor.default is selected, and select Duplicate …

__x. Enter the following ID and select OK: com.acme.workitem.editor.meeting

__xi. Click Save.

Eclipse client vs. browser client

Both RMC and RTC Eclipse clients allows for Jazz 
process template customization.  Although most features
are available in both Eclipse and browser clients, some 
features for modifying presentations is only available in 
the Eclipse client, so we have chosen to use this 
interface for this lab.

__b. Adjust presentation of attributes: you based your presentation in the default one which is
used by tasks. As the Meeting work item is a specialized type of task, you will be just 
adding a specialized tab for the new information and reusing the rest of the information.

__i. Click Add Tab … and enter the following values: 

__a. Title: Meeting Information

__b. Layout: Custom Attributes Layout

__c. Create Tab ID: CHECKED

__d. ID: com.acme.workitem.tab.meetinginformation

__e. Click OK.

__ii. High-light the new  tab and select Add Section …. Enter the following values, 
then select OK.

__a. Title: Meeting summary info

__b. Slot: Right 

__c. Create Section ID: CHECKED

__d. ID: com.acme.workitem.section.meetingsummary

__iii. Repeat the previous steps to add a new section with the following details:

__a. Title: Meeting minutes

__b. Slot: Left

__c. Create Section ID: CHECKED
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__d. ID: com.acme.workitem.section.meetingminutes

__iv. Highlight Meeting Summary Info section and click Add Presentation... for each 
of the items listed below. (do it in the order of appearance. All of them are 
“Attribute based”):

Attribute Kind Label Description

Formality Enumeration NA NA

Process Guidance
(rmc_guidance_attribu
te._rmc.meeting)

HTML NA Link to workflow description in process 
website.

Affected Departments String List NA NA

Affected Teams Process Area 
List

NA NA

__v. Now highlight Meeting Minutes section and click Add Presentation... for each 
of the items listed below (do it in the order of appearance):

Attribute Kind Label Description

Meeting minutes HTML NA NA

Work item type process guidance

When RMC creates a work item type, it creates a 
Process guidance attribute that links back to the process 
guidance.   If you look at  other work item types in this 
template, you will notice that we  used a different 
approach (using a non-attribute based presentation 
element).  This other approach is described in the RMC 
community topic Documenting work item types using 
RMC.

__c. Highlight the Meeting Information tab and click Move Up until you place it just after the 
Overview tab.

__d. Save your changes.

__e. Link the presentation to the work item:

__i. Navigate to the Types and Attributes node under Work Items.

__ii. Choose Meeting under Work Item Types

__iii. In the Work Item Editor box, select com.acme.workitem.editor.meeting

__iv. Save your changes.
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Different types of editors?

You may noticed that there are other type of editors in 
this page. The main differences are:

– Work Item Editor: the main editor for managing 
work items. Used in the different clients when 
you open a work item.

– Inline Work Item Editor: Inline editors are 
presented in the query results in the Web UI

– Lightweight Work Item Creation Dialog: 
presentation for wizards that allow for quick 
creation of work items, like when delivering 
change sets or from other integrated CLM 
applications.

– Plan Editor Preview: presentation for modifying 
work items from within a plan.

For all but the main editor, the default one usually is 
enough for the needs of your project, as they present the 
minimum basic set of attributes. However, you can also 
customize the other editors to your needs as we did in 
the example for the full editor presentation.

__f. Check the presentation.

__i. Select the arrow next to the New Work Item icon.

__ii. Select Nifty Application Project > Meeting. A new work item appears

__iii. Select the Meeting Information tab. It should look like the following:
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__9. Adjust permissions for attributes and workflow states: you have to give permissions to the roles 
for the new items created in the process.

__a. Return to the project area editor and select Permissions under Team Configuration 
node.

 Select under Team Configuration, not Project).

__b. Check the option to Show all actions and roles

__c. We will adjust permissions for meetings:

__i. Adjust permissions to the attributes:

__a. Open the node Work Items > Save Work Item (server) > Modify the work 
item

__b. Click Modify the 'Meeting minutes' attribute.

__c. Permit only the Scrum Master role to perform this action (remove the 
permissions  from other roles.

__ii. Adjust permissions for workflow:

__a. Open the node Work Items > Save Work Item (server) > Create a work 
item > Create a work item of a specific type
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__b. Under Create a 'Meeting' work item, CHECK the box for the Scrum 
Master and Product Owner roles, and UNCHECK for the rest of the roles.

__c. Open the node Save Work Item (server) > Trigger a workflow action

__d. Make sure the Scrum Master role is the only one with permission to 
perform  the Meeting workflow actions to complete minutes, close actions,
and close the meeting. All these workflow actions are part of the Meeting 
Workflow.

__d. Save your changes.
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3.3 Try out the changes

We will now try out the new meeting work item type.

__1. Create work items for Work Item type

__a. In the web UI, click Explore Project to return to the Nifty Application Project project 
dashboard.

__b. Click Work items > Create from template.

__c. Click Project Initiation and then click Create from template.

__d. Click the work item Share product vision.
Observe that it is of type Meeting.
Observe the new attributes that were added
Observe (and optionally click on) the RMC process guidance link See detailed 
description.

__e. Transition the work item through it's various states.

__i. Click the Planned dropdown then click Schedule.  Click Save.

__ii. Continue transitioning states as you wish. 

More to do

Normally we would also update the project dashboard to 
point to the new published process.  Since this was done 
in Lab 2, we do not repeat that here.

3.4 Gather the process changes

After successfully customizing the process in a living project, you want to gather changes back into the 
templates managed in your process development environment and managed by Rational Method 
Composer, so new projects can be created with these new items already defined.
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Customizing and testing in my production project?

The configuration steps in this lab were directly 
performed in the Nifty Application production project to 
focus in the features introduced. In your real production 
environment you would have a testing environment in 
which you validate process changes before applying 
them in production. This test environment, depending on 
your needs, could range from just a test project area in 
the production server, or a complete test installation. In 
lab 2 the Process Engineer customized the process 
using a test project area before gathering the changes 
back into the organization's process template.

Replicating process customization changes from your 
test environment in you real production project area can 
be performed in any of these ways:

– The Project Lead replicates all the modifications 
from the test project area. For this operation, the 
enterprise wide naming convention for the IDs of 
process elements outlined as best practice 
previously in this lab will be very useful.

– If test and production project areas are always 
aligned, Project Lead can copy the entire 
process source XML from test and replace the 
one in production project area. This operation is 
to be performed with extreme care.

We have omitted this test project area intermediate step 
for the sake of workshop timing and to concentrate on 
the main operations of the lifecycle.

You can also deploy process definitions using Process 
Sharing, where a Provider Project allows Consumer 
Projects to use its process definition. We do not cover 
this feature in this workshop.

__1. Generate the process template from the Project Area:

__a. Back in RMC, switch to the Jazz Admin perspective, and open the Team Artifacts view 

__b. Right-click the project area Nifty Application Project and select Extract Process 
Template...

__c. Give it the following values and select Finish.

__i. Name: Acme Nifty Based

__ii. ID: acme.nifty.processtemplate.v2

__iii. Summary: Nifty version 2.
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What if you want to reuse the template ID?

You cannot create a process template from a Project 
Area and assign it an ID of a process that already exist in
the repository. On the other hand, you can't delete a 
process template from the repository if a project area 
exist that was created based on it.

If you want to keep one corporate process template (and 
thus just one ID), you can generate a process template 
from a project area with the process shown here, export 
it and then re-import it giving it the existing ID; you will 
then be prompted to overwrite. 

Alternatively, you can use the Process Sharing feature.

Important! A process template generated from a 
project area doesn't consider localization, but is 
generated in the language of the project area 
instantiation.

__2. Export the Process Template:

__a. Back in the Process Templates view, right-click your newly created template called 
Acme Nifty Based and select Export.

__b. Select root/PEW/Downloads as the directory and click Finish.

__c. The file will be saved as root/PEW/Downloads/template

__3. Delete the temporary Process Template:

__a. Right-click the Acme Nifty Based process template and select Delete...

__b. Click OK when prompted

__4. Import the process template into the process development environment:

__a. In the Process Template view, right-click the “jim@ProcessDev” connection and select 
Import.

__b. Enter the following values in the Import wizard. Note that we are modifying the populated
ID and Name:

__i. Template Directory: CHECKED

__ii. Template Directory: root/PEW/Downloads/template

__iii. Name: Acme Process V2

__iv. Process ID: acme.process.v2
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__c. Select Finish. You have a new  process template that contains the customizations 
performed via the Nifty project.

__5. Update the process template under SCM:

__a. Right-click Acme Process V2 under the “ProcessDev” repository connection and select 
Export.

__b. In Directory field enter: root/PEW/Workspaces\Lab1\Acme Templates(It is your SCM 
workspace!). Select Finish.

__c. Change the perspective to Work Items.

__d. Open the Pending Changes view as follows:

__i. Click Window > Show View > Other...

__ii. Click Jazz Source Control > Pending Changes

__iii. Click OK

__e. Expand the Refresh button and click Refresh Sandbox

Select OK when prompted so you refresh the whole sandbox (you can check just the 
specific folder for the process template if you want).

__f. Right-click the Process Templates > Unresolved folder in the Pending Changes View 
and click Check-in and Deliver.  Type a comment (such as “Created V2”) and click 
Finish.

You have successfully updated your process development environment and the process templates with 
the latest changes.
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Final note: update template but keep localization
In these last steps of the lab you saw how to update your 
corporate process template gathering changes from a 
project area. However, there's no easy way in Rational 
Team Concert to perform this process generation from a 
living project keeping the externalized strings localization 
information. See Translatable Process Templates in 
Rational Team Concert 2.0

If you want to gather changes from a Project Area 
keeping this localization information, you will have to 
manipulate the XML of the Process Template to 
manually replicate the changes. Some possible 
approaches:

1. Manually replicate the changes directly in the 
process template if you have clear where the 
XML has been modified

2. Generate a temporary project area based on 
your template and compare with the new XML. 
Note that some structural changes (like change 
in the order of XML tags), may be possible.

3. Update the process template as you did in this 
lab, and then re-do the steps to add localization 
to the process template.
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	Lab 3 Configuring Work Items
	3.1 Update the process description
	3.1.1 Complete the process description of the new Work Item Type

	__1. Document the work item type in RMC
	__a. Switch to RMC. In the Authoring perspective, in the Library view, navigate to practice > mgmt > scrum > extend-acme > Method Content > Content Packages > acme
	__b. Right click and select New > Work item type
	__c. Enter:
	__i. Presentation name: Meeting
	__ii. Name: meeting (if preferences set correctly, this will be automatically set.
	__d. Add a predefined state diagram to the main description
	__i. Click the rich text editor icon to the left of Main Description.
	__ii. Click the Add image link
	__iii. Browse to add resources > meeting_states.jpg (Full path: rootPEWWorkspacesLab1practice.mgmt.scrum.extend-acmeguidancespracticesresourcesmeeting_states.jpg)
	__iv. Click OK
	__v. Add additional text as desired.
	__vi. Click Save.

	__2. Open the Pending Changes view. Right-click on the Process Extensions > Outgoing folder and select Check in and deliver. (If you are prompted to create a work item, create one).
	__3. Use the new work item type in a work item template
	__a. In the library view, open practice > mgmt > scrum > extend-acme > method content > content packages > acme > tasks > share_product_vision.acme (created in Lab 2)
	__b. Click on the Relationships tab (it may be elided, in which case you need to click the Show List icon to the right of the tabs).
	__c. Scroll down to the Of Type relationship section.
	__d. Click Add
	__e. Type meeting to filter the selections.
	__f. Click meeting. Click OK. Click Save.
	This change affects every place the task is used, including the Project Initiation workflow/capability pattern (as shown below in the Acme process website).
	3.1.2 Publish the new process description
	__1. Publish the changes to the server.
	__a. Under the Configuration menu, select Publish...
	__b. Make sure Use publish options stored in the method configuration is checked and Don't review publish options is selected (this will assure that the process will publish with the options defined in the configuration). Select Next.
	__c. Select acmeprocess in Method configuration and Next.
	__d. Make sure the option Java EE web application is selected with the following options, then select Finish. (Select OK when prompted to overwrite)
	__i. Directory: root/PEW/Downloads/acmeprocess
	__ii. Web application name: acmeprocess3
	__iii. Package format: WAR
	__iv. Leave other settings as defaulted.
	__e. Make sure the Publishing Report shows no errors then close the window.
	__f. Move the acmeprocess3.war file from root/PEW/Downloads/acmeprocess to root/PEW/IBM/JazzTeamServer/server/tomcat/webapps; (Replace any existing acmeprocess.war file).
	__2. Verify the changes
	__a. In your browser navigate to https://clm.process.ws/acmeprocess.
	__b. In the treeview, select Rational Team Concert > Work item types > Meeting and review the information.
	3.2 Customize the process in RTC
	__1. Create the Work Item type
	__a. Go back to RMC and switch to the Team Process perspective
	__b. Choose acmeprocess in the Method drop-down field
	__c. On the Team Process Navigator, select the option to display the treeview in Navigation mode.
	__d. In the treebrowser, right click Acme Process > Rational Team Concert > Work Item Types > Meeting
	__e. Click Create Jazz Work Item Type
	__f. Choose the following values and click Finish:
	__i. Project Area: Nifty Application Project (within the SoftwareDev repository)
	(Note: We are creating this in a “real” project to try it out. Later we will harvest this into ccm-pew and distribute it as a template to be used by new projects.)
	__ii. Context root: /acmeprocess3
	(Reminder: context root is the URL where process guidance is published).
	__iii. Workflow: Defect Workflow (leaving as default – we can update this later in RTC)
	__2. Replace the work item template for Project Initiation
	__a. Still in the Team Process Perspective, right click on Acme Process > Project initiation.
	__b. Click Create Jazz Work Item Template.
	__c. Choose the following values and click Finish:
	__i. Project Area: Nifty Application Project (within the softwareDev repository)
	__ii. Context root: /acmeprocess3
	__3. Make further changes to the work item type using RTC
	__a. In the browser, you should be in the Nifty Application Project area. Click the wheel icon at the top right , and click Manage this Project Area.
	__b. Click the Work items tab on the left.
	__c. Under Choose the Work Item Type to edit, click Meeting.
	__d. Click the Icon: Edit button and select an icon, such as adoption.gif
	__e. Save your changes.
	__4. Now we will add some custom attributes.
	__a. Navigate to the Attributes section of the page.
	__b. Select Add …
	__c. Enter the following values:
	__i. Name: Meeting minutes
	__ii. ID: com.acme.workitem.attribute.minutes
	__iii. Type: Large HTML
	__iv. Select OK.
	__d. Add another attribute:
	__i. Name: Affected Departments
	__ii. ID: com.acme.workitem.attribute.affdepts
	__iii. Type: String List
	__iv. Select OK.
	__5. Reuse existing attribute:
	__a. Select Add …
	__b. Check Reuse Existing Attribute and select “Affected teams” from the drop-down list
	__c. Select OK.
	__6. Define enumeration for the formality attribute:
	__a. Click the Enumerations tab
	__b. Select the Add... button located below Choose the Enumeration to edit
	__c. Enter the following values and select OK:
	__i. Name: Formality
	__ii. com.acme.workitem.enum.formality
	__iii. Process Specification: CHECKED
	__d. Select Add... at the Literals section, and enter the following values for the “Name” attribute of each literal value, you can leave the “External Value” field empty: (assign icons as you wish)
	__i. Select the value Low for Default Literal and Unassigned Literal
	__ii. Click Save
	__e. Create the attributes for the enumeration:
	__i. Click Types and Attributes tab
	__ii. Make sure Meeting Work Item Type is selected.
	__iii. Navigate to the Attributes section of the page.
	__iv. Select Add …
	__v. Enter the following values, then select OK:
	__a. Name: Formality
	__b. com.acme.workitem.attribute.formality
	__c. Type: Formality Do not select Formality (enumeration list). Formality let's you assign just one formality value for a meeting.
Formality (enumeration list) lets you assign multiple formality values.
	__7. Define the workflow: the Process Engineer described the workflow in RMC. Now you will create a work item workflow matching that description.
	__a. Select the Workflows tab.
	__b. Select Add... next to the Choose the workflow to edit field.
	__c. Enter the following values and then select OK:
	__i. Name: Meeting Workflow
	__ii. ID: meetingWorkflow
	__d. Navigate down to the States section. Click Add... button and create the states with the following information: (assign icons as you will).
	__e. Create the actions that cause the state transitions: in the Actions section of the page, perform the following:
	__i. Click Add
	__ii. Enter Plan as the name. For Target state click Planned. Select OK.
	__iii. Repeat steps i – ii, with the rest of these actions.
	__f. Describe the legal transitions (from state to state): navigate to the Transitions section of the page and perform the following changes:
	__i. In the combination From “Planned” To “Scheduled”, click the dropdown and select Schedule.
	__ii. Repeat with the rest of the transitions until you build the following transition table (which maps to the flow you described in Rational Method Composer earlier in this lab):
	__g. Define the start action:
	__i. Select the dropdown next to Start Action and click Plan.
	__h. Define the resolutions: you want to further explain the possible reasons for cancelling a meeting.
	__i. Navigate to the Resolutions section.
	__ii. Click Add...
	__iii. Enter No longer required as the name. Select OK.
	__iv. Repeat the steps to include a resolution called Duplicate.
	__i. Navigate back to the Actions section of the page and configure resolutions:
	__i. In the row for the Cancel action, click on Click to select Resolutions.
	__ii. Click Add All. Click OK.
	__j. Save your changes.
	__k. Associate the workflow to the work item:
	__i. Navigate to the Types and Attributes tab.
	__ii. Choose Meeting under Choose the Work Item Type to edit.
	__iii. In the Workflow dropdown, select Meeting Workflow.
	__iv. Save your changes.
	__8. Customize the presentation for the work item
	__a. For ease of use, you will create a presentation based on an existing one, customizing it to hold the required attributes.
	__i. Back in RMC, change the perspective to Work Items. (This is a Jazz/RTC perspective that happens to also be available in RMC).
	__ii. Click on Manage Connected Project Areas
	__iii. Select the existing repository connection then click Next
	__iv. Select all project areas then click Finish.
	__v. Change the view to Team Artifacts.
	__vi. Right-click Nifty Application Project [SoftwareDev] and click Open.
	__vii. Click the Process Configuration Tab.
	__viii. Click Project Configuration > Configuration Data > Work items > Editor presentations.
	__ix. Make sure in the Choose editor presentation to edit box the com.ibm.team.workitem.editor.default is selected, and select Duplicate …
	__x. Enter the following ID and select OK: com.acme.workitem.editor.meeting
	__xi. Click Save.
	__b. Adjust presentation of attributes: you based your presentation in the default one which is used by tasks. As the Meeting work item is a specialized type of task, you will be just adding a specialized tab for the new information and reusing the rest of the information.
	__i. Click Add Tab … and enter the following values:
	__a. Title: Meeting Information
	__b. Layout: Custom Attributes Layout
	__c. Create Tab ID: CHECKED
	__d. ID: com.acme.workitem.tab.meetinginformation
	__e. Click OK.
	__ii. High-light the new tab and select Add Section …. Enter the following values, then select OK.
	__a. Title: Meeting summary info
	__b. Slot: Right
	__c. Create Section ID: CHECKED
	__d. ID: com.acme.workitem.section.meetingsummary
	__iii. Repeat the previous steps to add a new section with the following details:
	__a. Title: Meeting minutes
	__b. Slot: Left
	__c. Create Section ID: CHECKED
	__d. ID: com.acme.workitem.section.meetingminutes
	__iv. Highlight Meeting Summary Info section and click Add Presentation... for each of the items listed below. (do it in the order of appearance. All of them are “Attribute based”):
	__v. Now highlight Meeting Minutes section and click Add Presentation... for each of the items listed below (do it in the order of appearance):
	__c. Highlight the Meeting Information tab and click Move Up until you place it just after the Overview tab.
	__d. Save your changes.
	__e. Link the presentation to the work item:
	__i. Navigate to the Types and Attributes node under Work Items.
	__ii. Choose Meeting under Work Item Types
	__iii. In the Work Item Editor box, select com.acme.workitem.editor.meeting
	__iv. Save your changes.
	__f. Check the presentation.
	__i. Select the arrow next to the New Work Item icon.
	__ii. Select Nifty Application Project > Meeting. A new work item appears
	__iii. Select the Meeting Information tab. It should look like the following:
	__9. Adjust permissions for attributes and workflow states: you have to give permissions to the roles for the new items created in the process.
	__a. Return to the project area editor and select Permissions under Team Configuration node. Select under Team Configuration, not Project).
	__b. Check the option to Show all actions and roles
	__c. We will adjust permissions for meetings:
	__i. Adjust permissions to the attributes:
	__a. Open the node Work Items > Save Work Item (server) > Modify the work item
	__b. Click Modify the 'Meeting minutes' attribute.
	__c. Permit only the Scrum Master role to perform this action (remove the permissions from other roles.
	__ii. Adjust permissions for workflow:
	__a. Open the node Work Items > Save Work Item (server) > Create a work item > Create a work item of a specific type
	__b. Under Create a 'Meeting' work item, CHECK the box for the Scrum Master and Product Owner roles, and UNCHECK for the rest of the roles.
	__c. Open the node Save Work Item (server) > Trigger a workflow action
	__d. Make sure the Scrum Master role is the only one with permission to perform the Meeting workflow actions to complete minutes, close actions, and close the meeting. All these workflow actions are part of the Meeting Workflow.
	__d. Save your changes.
	3.3 Try out the changes
	__1. Create work items for Work Item type
	__a. In the web UI, click Explore Project to return to the Nifty Application Project project dashboard.
	__b. Click Work items > Create from template.
	__c. Click Project Initiation and then click Create from template.
	__d. Click the work item Share product vision. Observe that it is of type Meeting. Observe the new attributes that were added Observe (and optionally click on) the RMC process guidance link See detailed description.
	__e. Transition the work item through it's various states.
	__i. Click the Planned dropdown then click Schedule. Click Save.
	__ii. Continue transitioning states as you wish.
	3.4 Gather the process changes
	__1. Generate the process template from the Project Area:
	__a. Back in RMC, switch to the Jazz Admin perspective, and open the Team Artifacts view
	__b. Right-click the project area Nifty Application Project and select Extract Process Template...
	__c. Give it the following values and select Finish.
	__i. Name: Acme Nifty Based
	__ii. ID: acme.nifty.processtemplate.v2
	__iii. Summary: Nifty version 2.
	__2. Export the Process Template:
	__a. Back in the Process Templates view, right-click your newly created template called Acme Nifty Based and select Export.
	__b. Select root/PEW/Downloads as the directory and click Finish.
	__c. The file will be saved as root/PEW/Downloads/template
	__3. Delete the temporary Process Template:
	__a. Right-click the Acme Nifty Based process template and select Delete...
	__b. Click OK when prompted
	__4. Import the process template into the process development environment:
	__a. In the Process Template view, right-click the “jim@ProcessDev” connection and select Import.
	__b. Enter the following values in the Import wizard. Note that we are modifying the populated ID and Name:
	__i. Template Directory: CHECKED
	__ii. Template Directory: root/PEW/Downloads/template
	__iii. Name: Acme Process V2
	__iv. Process ID: acme.process.v2
	__c. Select Finish. You have a new process template that contains the customizations performed via the Nifty project.
	__5. Update the process template under SCM:
	__a. Right-click Acme Process V2 under the “ProcessDev” repository connection and select Export.
	__b. In Directory field enter: root/PEW/WorkspacesLab1Acme Templates(It is your SCM workspace!). Select Finish.
	__c. Change the perspective to Work Items.
	__d. Open the Pending Changes view as follows:
	__i. Click Window > Show View > Other...
	__ii. Click Jazz Source Control > Pending Changes
	__iii. Click OK
	__e. Expand the Refresh button and click Refresh Sandbox
	Select OK when prompted so you refresh the whole sandbox (you can check just the specific folder for the process template if you want).
	__f. Right-click the Process Templates > Unresolved folder in the Pending Changes View and click Check-in and Deliver. Type a comment (such as “Created V2”) and click Finish.


