Prerequisites for integrating with Gerrit

Before you configure the integration between IBM® Engineering Workflow Management (EWM) and Gerrit, ensure that your environment meets these prerequisites.

Ensure that you have met the following prerequisites:

  • Gerrit is installed and configured. For more information on Gerrit server installation and configuration refer to Gerrit documentation.
  • Before you configure hooks in Gerrit 2.13.x and above, install the hooks plug-in. See Gerrit 2.13 Release.
  • The EWM server is installed and configured. For details about installing and setting up the EWM server, see Installing IBM Engineering Lifecycle Management.
  • The following software is installed on the Linux system that hosts the Gerrit server:
    • Node runtime
    • npm
    • sed
    • bash
    • git
  • On the system that hosts the Gerrit server, ensure that the following executables are available in the PATH environment variable:
    • nodejs or node
    • npm
    • sed
    • bash
    • git
  • To check whether git is available in the PATH environment variable, run the following command: $> whereis git. If it returns the following output, then git is not available in the PATH variable: git:. Otherwise, you should see output like the following: git:/usr/bin/git.
  • Repeat the above previous step to confirm that the other executables are in the PATH environment variable.

video icon Video

Jazz.net channel
Software Education channel

learn icon Courses

IoT Academy
Skills Gateway

ask icon Community

Jazz.net
Jazz.net forums
Jazz.net library

support icon Support

IBM Support Community
Deployment wiki