Upgrading the Build System Toolkit on IBM i

Upgrading a previous version of the Build System Toolkit to the new version of the IBM® Engineering Lifecycle Management (ELM) on IBM i requires that you install the new version toolkit and customize the startbfa.sh script with the same modifications that are in the previous version of the script.

About this task

There is no script to upgrade your existing Build System Toolkit on IBM i automatically to the new version, so upgrading requires that you install a new version of the Build System Toolkit and modify the startbfa.sh script manually.

Procedure

  1. Complete the licensed program installation process to install a new version of the Build System Toolkit. For details, see Installing the Build System Toolkit on IBM i systems.
  2. Locate the new version and the previous version of the startbfa.sh script and modify the new version with the same modifications that are in your previous version of the startbfa.sh script.
    Attention: Do not copy the previous version of the startbfa.sh script to replace the new version startbfa.sh script because there are significant changes, for example new default Java™ options.

video icon Video

Jazz.net channel
Software Education channel

learn icon Courses

IoT Academy
Skills Gateway

ask icon Community

Jazz.net
Jazz.net forums
Jazz.net library

support icon Support

IBM Support Community
Deployment wiki