Upgrading the Engineering Workflow Management clients for Microsoft Visual Studio and Eclipse IDE

If you are upgrading from a version 6 release of the client, you can use the Update option in IBM® Installation Manager to upgrade the client.

Before you begin

If you previously installed the client into an Eclipse 3.5 or 3.6 installation with the Eclipse p2 provisioning system, you must uninstall the p2 installation before installing the Eclipse client.

About this task

For supported versions of Eclipse, see Hardware and software requirements.

If you used a .zip file to install the previous Eclipse client, you can download the .zip file for the latest version and either extract it to the same directory and replace the old files or extract it into a new directory.

Note: To upgrade the Eclipse client by using the Update feature of IBM Installation Manager, the Eclipse versions must be the same. Otherwise, you cannot upgrade the Eclipse client and must install a new version of Eclipse. For example, the Rational® Team Concert® client for Eclipse IDE version 6.0.5 supports Eclipse 4.2, and version 6.0.6 supports Eclipse 4.4 and 4.6. As a result, if you upgrade from version 6.0.5 to version 6.0.6 or later, you must install a new Eclipse client.

Procedure

Complete these steps to upgrade the client for Microsoft Visual Studio or the client for Eclipse IDE:

  1. Open IBM Installation Manager and click Update.
  2. In the wizard, follow the instructions to update the client.
    Your repository workspace that is loaded from a previous version continues to work with the new version of the client. You do not need to reload your source code.