It's all about the answers!

Ask a question

RTC 4.0 Extensions Workshop: Cannot update permissions for global user "ADMIN".ID CRJAZ0709I

Frank Ning (50025119133) | asked Jan 19 '13, 9:15 p.m.
edited Jan 20 '13, 2:28 a.m. by Ralph Schoon (63.2k33646)


My understanding could be wrong for 1.3 _17 h) on page 24 about assigning licenses to "ADMIN" ID:

1) I don't see "ADMIN" ID on the "Active Users" list (I did not disable the "ADMIN" ID)

2) When I logged in as "ADMIN" and used "View my profile and licenses" to assign licenses to "ADMIN" ID, the following error was shown when I clicked "Save":

Cannot update permissions for global user "ADMIN".ID CRJAZ0709I
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
$Proxy238.updateExternalUser(Unknown Source)


Accepted answer

permanent link
Frank Ning (50025119133) | answered Jan 20 '13, 9:10 a.m.

Hi Ralph,

I solved the license issue for "ADMIN" ID by using the Web UI to reassign the license assigned to ADMIN previously to the permanent one. The "ADMIN" profile really can not be modified via other method as I tried via both Web UI and RTC client.

Ralph Schoon selected this answer as the correct answer

Ralph Schoon commented Jan 20 '13, 11:42 a.m.

I am pretty sure that I could not get to that user in the web UI. Anyway, if you solved it, I am happy. 

2 other answers

permanent link
Jay Witherspoon (1368) | answered Mar 28 '14, 8:02 a.m.

Sorry to bother you, but could you give more details about the steps you took to:

"using the Web UI to reassign the license assigned to ADMIN previously to the permanent one."

I am having the same issue and do not understand what you mean...

Ralph Schoon commented Mar 28 '14, 8:43 a.m.

I can not comment on what Frank did.  I am not sure what the issue is, you run into and which step.

In general, by doing the repotools import, the ADMIN user should have a developer license assigned. By uploading the 10 Free license, the (expired) evaluation license should be replaced by it and the ADMIN user should automatically have the correct license assigned.

If this is not the case, make sure that

  • the 10 Free License is successfully uploaded using the Web UI
  • Try to open the ADMIN user profile in the ECLIPSE UI and check that ADMIN has the license assigned (you need to do this in the Eclipse UI, because you will not find the user profile for ADMIN in the Web UI)

permanent link
Ralph Schoon (63.2k33646) | answered Jan 20 '13, 2:17 a.m.
edited Jan 20 '13, 2:18 a.m.
 You can only reach the user profile for ADMIN using the Eclipse client. 
In addition you have to make sure not to deactivate that user during the setup.

Frank Ning commented Jan 20 '13, 8:59 a.m.

Hi Ralph,

It still does not work.

1. The ADMIN was not disabled during the jts/setup. ADMIN can be used to login without issue

2. RTC client is now used with two approaches, both failed with the same error "Save conflict detected" even the tomcat server was restarted, same error. The pop-up details shows:

"The user in the repository is more recent than the version you are editing. This usually means that another client has edited the user while this editor was open. Refresh the editor and try again".

The error does not make sense to me since it is not true:-). Restarting the tomcat server gave the same error.

1) login project area as "ADMIN" and use "Open my User Editor" to add a license, failed

2) login as "myadmin" and open the "ADMIN" user profile via "Administrator -> Open Users" to add license to "ADMIN" ID, same error.

Any advice?

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.