It's all about the answers!

Ask a question

Cannot import records from CQ to RTC


Ziv Rechnitser (91618) | asked Jan 10 '13, 3:24 a.m.
Hi All, We try to import records from CQ version 6.15 to RTC version 3.0.1. When I get the stage that I need to select the query from the CQ, this error message appears "An error has occurred while retrieving query folder" and I can see in the log this error:"The version 20030615 of CQ currently installed is incompatible with version 71 of the CM API in the CQ gateway. Ensure that the CQ gateway runs on a server where the CQ version installed is at least at level 7.0.1.‏" I looked in this article - "https://jazz.net/library/article/378/" and I don't thing its the solution. Maybe the problem is with the versions of the product? I will glad for hey help.

Thanks,

ZIv

Accepted answer


permanent link
KrishnaKanth Naik (7651915) | answered Jan 10 '13, 5:32 a.m.
JAZZ DEVELOPER
Hello Ziv

Adding to Ralph's update. The Synchronizer that are uploaded for customer download are meant for active releases only. As you would have noticed, there is a huge amount of architectural changes that went into 7.x that makes CQ and RTC communication compatible.

If you are looking at exporting all the records from CQ in to RTC, you could try the csv import option.

Few related links:
RTC 3.0.1 CSV Workitem import
Does RTC support to import the records from CQ, as BugZilla

CSV format and example


Ralph Schoon selected this answer as the correct answer

Comments
Ziv Rechnitser commented Jan 10 '13, 5:58 a.m.

Tanks Ralph and Krishna.

I will try to use the CSV file solution.  

One other answer



permanent link
Ralph Schoon (56.3k23642) | answered Jan 10 '13, 4:28 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Ziv,

the message text
"The version 20030615 of CQ currently installed is incompatible with version 71 of the CM API in the CQ gateway. Ensure that the CQ gateway runs on a server where the CQ version installed is at least at level 7.0.1.‏"

and you mentioning
We try to import records from CQ version 6.15 to RTC version 3.0.1

clearly points into the direction of an incompatible version of CQ.

Your answer


Register or to post your answer.