Error with widgets in RTC
Hi,
I have the CLM Products (v4.0) installed on a Websphere server, served by DB2 databases. Both RQM and RRC work fine and the widgets on the dashboards load correctly for these products.
However in RTC, all RTC projects have a problem loading the widgets. On the dashboards I get the following error:
An error occurred while loading the widget.
Error: Unable to load https://testserver:9443/ccm/viewlet/com.ibm.team.dashboard.viewlets.web.static?dojo.preventCache=1357652811288 status:500
Error 500: java.lang.NoClassDefFoundError: com/ibm/team/dashboard/internal/web/ViewletDefinition
If I try add a new widget I get the following error:
Failed to add widget: Unable to load https://testserver:9443/ccm/viewlet/com.ibm.team.dashboard.viewlets.web.persona?dojo.preventCache=1357653772751 status:500
Can anyone shed any light on why I am hitting this issue. Any idea what I can do to fix this problem?
Accepted answer
Hi Anthony,
Ralph is correct.
Please go to the respective Admin Web UIs for the JTS & CCM servers and check to see if there are any server configuration errors. The error you received seems to indicate that the Dashboards component was not installed properly in your CCM server.
Please open a work item against the "Jazz Foundation" project and file it against "Web UI\Dashboards" with all of the pertinent details:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.newWorkItem
Comments
Anthony Paul
Jan 14 '13, 6:04 a.m.Ralph Schoon
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER Jan 14 '13, 7:28 a.m.