It's all about the answers!

Ask a question

Running HP QTP Scripts via RQM - Required Server Configurations


anoop mc (74810169214) | asked Jan 07 '13, 3:54 a.m.
edited Nov 21 '13, 2:29 p.m. by Lisa Caten (342913)
 Hi,

We are planning to install the QTP Adapters for running the scripts via RQM. Please let me know your suggestion before proceeding.

RQM Version: 2.0.1 iFIX5
QTP Adapter Version: RQM-QTP-9.x-Adapter-v2.0.0.3
QTP Server Version: 10.0
Platform: Windows Server

Having gone through the readme.txt file and below are the steps being followed.

We have downloaded the adapter from Jazz.net and after extracting the .ZIP file it contains 3 files.

extracting_qtp_adapter

################################################################

Steps : ( Installation to be performed on RQM Server)

1. Copy "QTPAdapterWebUI.zip" to an install location and unzip it (e.g. c:\). This ZIP archive contains a com.ibm.rqm.adapter.qtp.web.update    directory and a com.ibm.rqm.adapter.qtp.web.ini file. 

2. Find com.ibm.rqm.adapter.qtp.web.ini file in the zip archive extract. Edit the file, changing the "URL" property in the .ini file, to point to the   location where the com.ibm.rqm.adapter.qtp.web.update directory is located and then save the .ini file. 

  For example:
  url=file:C:/com.ibm.rqm.adapter.qtp.web.update 
  featureid=com.ibm.rqm.adapter.qtp.web.feature 
  Note: Use forward slash (/) for file separator as shown above. 

3. Copy the modified com.ibm.rqm.adapter.qtp.web.ini file to <RQM install root> "c:\Program Files (x86)\IBM\RQM201\server".

4. Use the Rational Quality Manager Server Reset service to update the server configuration. The reset utility is found at the following URL: 
   https://<hostname>:<portnumber>/jazz/admin?internal#action=com.ibm.team.repository.admin.serverReset

   The service will prompt you to login to the IBM Rational Quality Manager Admin console. Note: the user ID must have administrator privileges.

5. Restart Rational Quality Manager server.

#########################################################################################

Steps : ( Installation to be performed on QTP Server)

1. Extract the QTPAdapterInstaller.zip file

2. Before Installing QTPAdapter manually make sure that the ZIP archive file (“QTPAdapterInstaller.zip”) has the following content.
QTPAdapter.zip
InstallQTPAdapter.vbs
ManualInstallationForQTPAdapter.doc

3. Extract the “QTPAdapter.zip” to a location where you want to have the QTP adapter installed, for example in “C:\QTPAdapterHome”.  This will create    a directory “QTPAdapter” at the selected location. (“C:\QTPAdapterHome\QTPAdapter” referred to as <Install Home> henceforth).

4. Set JAVA_HOME in <Install Home>\bin\launchQTPAdapterConsole.bat file to point to Java 1.5 (IBM or Sun JRE 1.5) or later versions installed on the    host machine. 

   For example add the following line in “launchQTPAdapterConsole.bat” file: 
   set JAVA_HOME=C:\Program Files\IBM\Java50\jre

5. Add following lines at the beginning of <Install Home>\bin\scriptRunner.vbs file: 

        Dim qtpInstallHome 
        qtpInstallHome = <Quick Test Professional Installation Root> 

   For example, add the following lines in <Install Home>\bin\scriptRunner.vbs file: 

   Dim qtpInstallHome 
   qtpInstallHome = "c:\Program Files (x86)\HP\QuickTest Professional"
 
6. Create shortcuts on the Desktop and Start Menu for <Install Home>\bin\launchQTPAdapterConsole.bat

7. Run launchQTPAdapterConsole.bat from command-prompt or double click “launchQTPAdapterConsole.bat” file to start the adapter.

Regards
Anoop

16 answers



permanent link
anoop mc (74810169214) | answered Nov 18 '13, 10:42 p.m.
edited Nov 18 '13, 10:45 p.m.
As we were busy with other releases this qtp to rqm testing was on hold for sometime.

Resuming the same from where we left off, we could successfully run the qtp script from the qtp server and during the script execution the recorded pages were played back.

With help of server administrator we tried running the same script locally using Firefox Browser, execution went well but the recorded pages were not displayed.

Solution to be identified for the issues which we have come across is:

  1. Why only one QTP user is able to run the test. (If multiple user sessions are there it says “QTP is busy with operation “) even though we have 4 licenses.

Workaround
: Go to task manager and see if there are multiple QTPro.exe process running under a different user name. If so kill those sessions and rerun it works.

2.  What could be done to make the script execute locally via RQM (so that testers can run the test)?

Note: Testing team wants to run the QTP test just by launching the RQM Web browser. Is this recommended.

3. Why the Shared Path (\\<ServerName>\folder1\folder2\QTP_WORKSPACE\) is not accessible from the tool, where as the same is accessible via Start > Run

When accessed from tool it says " the shared path is not a known / accessible share. Please contact QM admin.

(Refer to screen shot below)
shared path err
 



permanent link
anoop mc (74810169214) | answered May 07 '13, 4:20 a.m.

Below are some of the lessons we learned during the QTP RQM integration.

  • The RQM login account should have connector licenses.
  • The user (admin) who does integration should have access to the server where QTP is installed.
  • The Adapter ID should be unique for each project area.
  • We were not able to display the test script project even though we gave the project path. This is because we were missing one level of folder structure. ( as shown below)
  • rqm_qtp_correct_folder_structure


permanent link
anoop mc (74810169214) | answered Mar 19 '13, 6:21 a.m.

Hi,

Based on my interaction with RQM Development team and various SMEs here are some useful information which answer my question above.

  • If a QTP test is going to be run on a machine, you will need exclusive access to the machine anyway.  A user must be logged on and the screen unlocked for QTP to run GUI tests.

  • A single adapter instance can only connect to one project area at a time. This is true for all RQM adapters. ( Reason: Most of the test teams have separate assets.The same machine can be shared between multiple project areas based on different time slots.)


permanent link
anoop mc (74810169214) | answered Mar 14 '13, 6:26 a.m.
May I ask, what is the usecase you are trying to achieve by having same QTP adapter appear in multiple project areas?

Our Scenario is as below
In an Instance of RQM we have multiple project areas created.
for eg: 1. Quality Manager  || 2. Test  etc.
Project Area and Adapter name
For the above project area, named : Quality Manager we have the adapter console with all the information. When you click on start adapter button then only the adapter name show up in the RQM window. (Is there any way we can configure this .bat file to run as a windows service)
While testing this out I have asked the Server Admin to login into the QTP server and launch the launchQTPAdapterConsole.bat , then click on Start Adapter
This QTP Adapter ( launchQTPAdapterConsole.bat - Shortcut) is located on QTP Server.
My First requirement is:
How to make this launchQTPAdapterConsole.bat - Shortcut  run automatically without being manually started.
Second Requirement :
How to configure the new adapter for my other project area - Test
Hope my scenario is clear to you ..

permanent link
Vaibhav Srivastava (2861) | answered Mar 14 '13, 4:23 a.m.
JAZZ DEVELOPER
Each adapter appears in one project area at a time. In-order to have an adapter from a machine into multiple project areas you would have to start multiple instances of the adapter (these will be seperate instances).
May I ask, what is the usecase you are trying to achieve by having same QTP adapter appear in multiple project areas?

Also, Command line adapter runs batch files or similar executables, so essentially by modifying the command line batch files, you could run multiple test (with a caveat that in RQM only one test execution result will be created for the whole test). For QTP, as far as I recall it runs one script, however I would imagine you can use that 'startup' script to invoke multiple QTP tests. For that you would need to organize the tests in QTP to achieve the same.

Hope that helps.

permanent link
anoop mc (74810169214) | answered Mar 12 '13, 6:02 a.m.
Can’t we create dedicated adaptor console for each project area?


permanent link
anoop mc (74810169214) | answered Feb 05 '13, 8:46 a.m.
 Now CLA testing look fine.

HP QTP Adapter also woks for me now

Steps which I have performed is 

  1. Log back into the server (QTP Server)
  2. Run launchQTPAdapterConsole.bat from command-prompt or double click “launchQTPAdapterConsole.bat” file to start the adapter
  3. Log Back into RQM 
  4. checked in RQM if adapter is available for that particular project area.
  5. Finally it appeared.
Doubts which I have based on this configuration scenario is :

multiple project area
>  Here as shown above in the diagram "Quality Manager" is the only project area where the adapter will be made available.  If we want the same QTP adapter to appear on multiple project areas what is the procedure.

Is it one Project Area at a time. 

For Command Line Adapter we can execute the batch file from the machine we run the test. In Case of QTP Adapter not sure how it works.

permanent link
anoop mc (74810169214) | answered Jan 29 '13, 5:52 a.m.
 for CLA (Command Line Adapter) Testing:

After looking at each lines carefully and rerunning CLA testing worked. I am briefing the things which I have done.

What I have done is 

Step1:
Copied the RQMCommandLineAdapter.zip file to Java Installation Directory > C:\Program Files (x86)\Java\jre6\bin\

Step2:
Extracted the RQMCommandLineAdapter.zip file to a new folder by name ADAPTER ( which I have created manually)

Step3:
Ran the command Java.exe from the ADAPTER folder > which returned the java version
C:\Program Files (x86)\Java\jre6\bin\ADPATER>java -version
java version "1.7.0_04"

Step4:
Opened the command Prompt and from the path executed the batch file which returned a series of values and finally showed as created Commandline Adapter

C:\Program Files (x86)\Java\jre6\bin\ADPATER>start.bat -repository https://rqmpre:9443/jazz -user XXXXX -password XXXXX -adapterName cliadapter -projectArea PROJ_NAME
Launching Command Line Adapter...

java version "1.7.0_04"

Successfully created an HTTP client
java.security.NoSuchAlgorithmException: SSL_TLS SSLContext not available
Unable to create SSL_TLS context, trying TLS
The adapter is now connected
Unable to determine RQM server version. This is expected for RQM 2.x and earlier
 servers.
Unable to determine RQM server version. This is expected for RQM 2.x and earlier
 servers.
storeProperties: Failed to save configuration file for the command line adapter
Created Commandline Adapter

Step5:
Keeping the command prompt open

I have logged into RQM project area and checked the Adapter Console to see if the adapter appears there now.

Finally it appears. 

Note: I have tried with multiple users and in all the cases the adapter appears.

Command Line Adapter

permanent link
anoop mc (74810169214) | answered Jan 28 '13, 7:49 a.m.
 Hi Reshma,

As suggested , I have checked both the steps mentioned in the above post and could see everything is proper.

Let me put it simple  > I have got three machines

1. MACHINE A  [RQM Server]
2. MACHINE B  [QTP Server]
3. MACHINE C  [My local Desktop accessing MACHINE A via WEB UI]


What has been done earlier for QTP Adapter Testing:

1. Deployed the QTP adapter Web UI files on MACHINE A
2. Installed and Configured the QTP Adapter.VBS file on MACHINE B

3. After having starting the Adapter.VBS on MACHINE B, FROM MACHINE C logged into    RQM Web Interface 

4. Navigate to Construction > Create Test Scripts 
5. Chosen the Adapter Type as HP Quick Test Professional 9.X
6. Chosen the option "Use the test resources that are local to a test machine"
7. Select Adapter

No Adapter getting listed.


 what has been done for CLA (Command Line Adapter) Testing:

1. Got a copy of RQMCommandLineAdapter.zip from a machine to MACHINE C
2. Open the Command Prompt from MACHINE C
3. Navigate to the ADAPTER folder and ran the command start.bat -repository       https://rqmpre:9443/jazz -user <username> -password <password>  adapter         <cliadapter> <ProjectArea Name> -sleepTime 30 -configFile c:\config.ini
4. From MACHINE C opened the Firefox Browser - Launched the RQM Web interface
5. Navigate to Construction > Create Test Scripts
6. Chosen the Adapter Type as Command Line Adapter
7. Chosen the option "Use the test resources that are local to a test machine"
8. Select Adapter

No Adapter getting listed.


permanent link
anoop mc (74810169214) | answered Jan 28 '13, 4:30 a.m.
 Hi Reshma,

Referring to the setup instructions - See Setting up and starting the command line adapter.

It is said that u can use a machine as a target test machine for command-line execution. You must register the adapter on the target test machine to run command-line scripts.

Here in my case I am using the same machine ( Desktop) for running the manual tests. ( Via RQM web UI). So I suppose the target test machine to be the same.

target test machine

What I have done is copied the RQMCommandLineAdapter.ZIP file from a different server and ran the batch file with the command line arguments as shown below ( This is done on my local desktop) which returned the output. 

running the CLA

Still I do not see anything being listed.


Comments
Reshma Ratnani commented Jan 28 '13, 4:59 a.m.
JAZZ DEVELOPER

To me it seems to be permission issue because with commandline adapter also it is giving same issue. I would suggest you check 2 things:

1) On Adapter Console Page see if the adapter gets listed or not. If not then hide Machine column using Display Setting Action button. See if now you can view the adapter in the list

2) Check if the user which you are using for connecting the adapter has permission to create/ execute TestCase/ TestSuite, create/ modify/ take adapter request and create Execution Result. Also you should have alteast Connector license

Your answer


Register or to post your answer.