It's all about the answers!

Ask a question

Unable to save Mail Configuration due to remote exception

Jeff Ong (14113846) | asked Jan 03 '13, 3:49 p.m.
edited Jan 03 '13, 3:54 p.m.
We tried to update the "Mail Configuration" of one of our users using the Rational Team Concert Client (Version: Build id: RTC-I20120326-1442) but when we clicked on save, we go this error,
Remote exception was of type '$RestCommunicationException'  Error on server processing request.  See server logs for details.

Remote Exception error
Meanwhile in the jts.log, we got this error,
2013-01-03 15:42:02,405 [             WebContainer : 47] ERROR ibutor.internal.ContributorRecordUpdateRestService  - Error processing contributor record PUT from client server.domain Failed to find delta predecessor [UUID _h62WcJfsEd6OkM5ym4J-gQ]
Updating other users' Mail Configuration seems to be fine.

Has anyone seen this error before ?

4 answers

permanent link
Jeff Ong (14113846) | answered Jan 25 '13, 4:52 p.m.
Hi Craig, Your suggestion of removing the photo fixed the problem.  The user is now able to make changes to her mail configuration.  Thank you very much.

permanent link
Jeff Ong (14113846) | answered Jan 04 '13, 1:28 p.m.
edited Jan 04 '13, 1:32 p.m.
Hi Craig,

Thanks for the reply.

When we upgraded from RTC 2.0 iFix 04 to 3.0.1 almost 2 years ago, we didn't hit this issue.  Just noticed it now when the user tried to update her mail configuration.  The user does have a picture in her profile.  Since bug 191577 does mention issues with photos, do you think removing her photo and then updating the mail configuration will work ?

The mail configuration isn't available on JTS from a browser.

When we tried it from CCM/JAZZ from a browser, we encounter this problem,

An error occurred while trying to assign the Client Access License keys to the user. Click "show details" to view the details of the license assignment error. Follow the instructions to fix the problem, and click "Save" to try again.ID CRJAZ1846E

This problem is addressed in and defect 167290.

Craig Chaney commented Jan 09 '13, 6:51 a.m.

If you're only on 3.0.1, you will need to move up to or later to fix the issue.  The fix happens during the migration to

As a workaround, sometimes just resaving the user (either on the JTS or CCM) will repair the database record, so you might try removing the photo or making some other edit.

permanent link
Craig Chaney (9212) | answered Jan 04 '13, 6:23 a.m.
This looks similar to bug 191577.

The upgrade process should have fixed this.  Did you run the repotools addTables command on each of your applications when you upgraded to

You can also try using the web client to modify this user, this will sometimes succeed when the RTC rich client fails.  Try doing this on CCM and JTS.

permanent link
VK L (8177152159) | answered Jan 04 '13, 4:32 a.m.
Hi Jeff,
            Is this user's ID archived in RTC?


Jeff Ong commented Jan 04 '13, 12:01 p.m.

Hi Valli,

Thanks for replying.  No.  The userid isn't archived.

Your answer

Register or to post your answer.