It's all about the answers!

Ask a question

How to make RTC client (Linux) accept HTTPS cert with common name not matching URI?

Dennis LaRue (835) | asked Jan 03 '13, 11:06 a.m.
I recently switched from Windows to Linux.  I'm running RTC 3.0 on Linux now.  I was able to re-establish connections to most of my repositories.  However, one is giving me problems.  It says my credentials (id/pw) are bad.  I can use the same URI and credentials to connect to the repository using the web interface with Firefox if I approve a security exception.  The common name in the SSL cert  doesn't exactly match the URI.  I suspect this is the cause of the connection problem the bad credentials message is simply bad error reporting.

For some reason this worked OK under windows.  I'm new to Linux so maybe I'm missing some simple configuration setting?

Thanks in advance,

One answer

permanent link
Kevin Ramer (4.5k9185200) | answered Jan 03 '13, 4:26 p.m.
The first connection attempt ought to have asked what you'd like to do with the certificate being posed by the server.   I recall there are 3 options:  Reject and do not connect (selected !!), Accept permanently, accept for now.

If you chose Reject, the prompt keeps returning, so I doubt that's the issue.  You could try removing this repository from your Connections (Team Artifacts / Repository Connections) and recreate it.

Does your ID happen to have any mixed case ?  This can catch folks as the RTC server can respect case (default) of IDs.

Dennis LaRue commented Jan 03 '13, 4:39 p.m.

It never asked me anything about the certificate.  I watched a connection attempt with wire shark and even though encrypted I could see that it got past the SSL handshake.  I'm now thinking the cert issue might be a red herring.

I've removed and re-created the repository connection many times.  Sometimes using the team invitation and sometimes just making the connection by hand.  Always the same result.

My team invite had my ID in all lower case and that's what I've always used.

I haven't yet been able to find anyone administering the server.  Once I do I'm hoping they can shed some light on the matter.  It's just weird that I can connect to the repository using the same credentials from a Windows based client as well as a few other repositories with the same credentials from the Linux box.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.