It's all about the answers!

Ask a question

Invalid username or password error

Jagdish Gujar (611) | asked Dec 20 '12, 5:32 a.m.
retagged May 25 '13, 4:27 p.m. by Scott Rich (57136)

My setup is as follows:

Jazz: CLM 3.0.1

OS: Windows 2008 STD 32 bit

DB: MS-SQL 2005 (remote)

Auth: Tomcat with Windows LDAP

I am not able to login with LDAP user (which was working everyday and is in JazzAdmin AD group) and also not with ADMIN.

Please give me some leads.

Arne Bister commented Dec 20 '12, 1:16 p.m.


are you able to login with any user?
Can you login with this LDAP user in any other application on your machine?
Has anything changed with Tomcat and/or Database configuration?
Is the network connection from server to database stable?

Just a couple of leads that I can think of.

- Arne

Jagdish Gujar commented Dec 21 '12, 12:46 a.m.

Hi Arne!

I am not able to login with any user on the URL - not even with ADMIN. If ADMIN would be able to login, I was thinking of running setup again.

I am not able to login with any LDAP user on any application like CCM or RQM.

No changes have been done on the Tomcat or DB configuration.

Network is also stable between Jazz server to DB and LDAP servers.

I suspect Windows patch updates on the weekend which are forced by our organization.

My thoughts:

If ADMIN will be able to login, I will run setup again.

I am planing to create another Jazz server with same hostname and install all applications there and point to the same databases. I have taken backup of the databases.

Please help/suggest.



2 answers

permanent link
Karl Weinert (2.0k52736) | answered Dec 21 '12, 8:42 a.m.
Have you looked in the Tomcat logs? Frequently they will contain information on LDAP related problems.

Here's what I would do next
Install Wireshark on the Jazz server
See this tecnhnote for instructions on using it.

Start Wireshark as described in that technote.
Attempt to log in one or two times as a user in the LDAP registry.
Stop the capture
Type ldap into the filter box on the top left and click apply
This should be all the traffic to your ldap server and might give a clue as to what the problem is.

Check your files to make sure none of them have been changed recently.
The top 2 lines in the file should indicate when it was changed and by who if it was done through RTC.
Otherwise you will need to rely on the time stamps.

You can also verify that the LDAP settings look correct in those files

Check the tomcat server.xml file in the ...\server\tomcat\conf directory for the  className="org.apache.catalina.realm.JNDIRealm  element.
If it is there make sure the values look ok.
(not to be confused with the className="" element)

I don't think you can re-enable the ADMIN account once you switch to LDAP but you can give it a try by setting in the jts file and restarting the server.

permanent link
Nhi P Ta (18841018) | answered Dec 21 '12, 8:51 a.m.
Hi Jagdish,

You might want to try disable LDAP from file and revert back the to tomcat-user.xml in server/tomcat/conf.

Jagdish Gujar commented Dec 25 '12, 4:04 a.m.

Thanks Arne, Karl and Nhi P Ta!

This is what I tried and it worked!

I created another VM of 64-bit Windows OS. Took backup of the databases. I installed the IM and JTS. Then I copied the <JazzServerHome> from older non-working m/c to this one. I could login with my LDAP a/c! I just ran the setup and gave "repotools -ResetRepoLockId" when required. And every data item is back!

I got so many good leads from you which are useful and I will save them!

Thanks so much,


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.