It's all about the answers!

Ask a question

Advanced Properties option inactive _ generating new test enviornments tab


anoop mc (74811199221) | asked Nov 21 '12, 8:38 a.m.
Hi,

I have created a new test plan enviornment type referring to here ( http://publib.boulder.ibm.com/infocenter/rqmhelp/v2r0/index.jsp?topic=/com.ibm.rational.test.qm.doc/topics/t_cust_tp_env_types.html)

As a next step when I tried to generate a test execution record I dont see my new custom enviornment type being listed there.

One of the article says you need to select Advanced Properties button to show / hide enviornment while choosing attributes from Generate test enviornments tab.

Got stuck at this point.... any suggestions ?

Accepted answer


permanent link
Pramod Chandoria (2.1k11220) | answered Nov 22 '12, 6:32 a.m.
JAZZ DEVELOPER
I was talking about this option



The advanced property you are talking about becomes active when you select check box in two or more columns
anoop mc selected this answer as the correct answer

5 other answers



permanent link
anoop mc (74811199221) | answered Nov 23 '12, 2:11 a.m.
Hi Pramod,

Thanks for your patience and followup ..  finally the issue is resolved.

I am attaching a screen shot which I followed as a three step process.

Defining new test env types

permanent link
Pramod Chandoria (2.1k11220) | answered Nov 22 '12, 11:59 a.m.
JAZZ DEVELOPER
I think you need to define new type under Installed Software
Right, so first step is to define it under "Lab Resource Properties" selection as shown in pictured uploaded by you
After that as a next step select "Test Plan's Environment types" just below "Lab Resource Properties"
Then in this page, set Set Type as shown in the picture posted by me, Click Save button to save the settings
After this logoff and login again
Now you should be able to see the new test enviuronment type you added
In case you are generating Test Environment from "Test Environments" section of Test plan then make sure first you add "Screen Resolution" type in Platform Coverage tab







permanent link
anoop mc (74811199221) | answered Nov 22 '12, 8:24 a.m.
Hi Pramod ,

thanks the advanced property got active .But still I did not get what I was expecting.

I have created a new test plan environment type by name > Screen Resolution and populated with two values.

This Screen Resolution I want to appear while generating new Test Environment for a test case.

New Test plan env type

permanent link
anoop mc (74811199221) | answered Nov 22 '12, 2:01 a.m.
Hi Pramod,

In the second below Advanced properties option is greyed out for me.

As a next step go to Test plan Environment Type tab in same advanced properties


I have verified the permission level for my login and could see that I have full rights. Attached is the snapshot of the same.

Advanced Propertied Button Inactive

permanent link
Pramod Chandoria (2.1k11220) | answered Nov 21 '12, 2:50 p.m.
JAZZ DEVELOPER
You first need to define the test environment as you might have done already.
As a next step goto Test plan Environment Type tab in same advanced properties
Select the environment you created
Click on action button "Set Type"
Click Save
Log out from RQM and Log in again
Now you should see this new type available for generating Test Environment

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.