It's all about the answers!

Ask a question

Issues upgrading CLM to 4.0.................

vinay kumar bondugula (7312768) | asked Oct 29 '12, 5:15 p.m.
retagged Nov 05 '12, 12:17 p.m. by Bo Chulindra (1.3k2718)
Recently I have tried upgrading CLM to 4.0 on production server after trying it successfully on other server for trial.
I followed the upgrade document and started with migrating data from to repositories of 4.0, then migrating the applications(ccm,qm & rm(offline)).
There are no errors while migrating, it was successful. Even the LDAP which I have configured to the earlier one is also migrated.

When I tried to open the web client using the hostname of the server in URL, after the login the hostname automatically changed to the full name of the server i.e. including domain name(eg.

On the home page of the web client, on the right hand side I could not see " Create Lifecycle Project ", and when I tried to select "Manage Lifecycle Project" I got the following error:

" The server is offline or unreachable"

and when I continue for rm migration online it is giving the following error:

ID CRRRW7611W. The server was unable to generate the list of artifacts in a reasonable period of time.........................

ID CRRRW7557E The application has been waiting for some time for the server to respond to a request.

CRJCA0056E   An error occurred while processing an OAuth challenge. No OAuth consumer is             configured. 

Status Code 500
Sub status code 500

I could not even create a dashboard or access any project or personal dashboard.

We used the trial licenses earlier with CLM and those were expired long back and now we got the original licenses for 4.0.


vinay kumar bondugula commented Oct 29 '12, 5:16 p.m. | edited Oct 29 '12, 5:19 p.m.

Can any one help me with these issues....please do the needful

Thank you.

2 answers

permanent link
Anthony Kesterton (7.5k7180136) | answered Oct 29 '12, 6:45 p.m.
Can you check your server logs - it sounds like problems on the server.

Also - look at the user you are using in the admin page - and make sure you have the right license assigned.


vinay kumar bondugula commented Oct 30 '12, 1:50 a.m.

I forgot to inform that, the server is too slow. It almost takes 3-5 minutes to open server home page or others.

Anthony Kesterton commented Oct 30 '12, 5:12 a.m. | edited Oct 30 '12, 5:14 a.m.

So this definitely is a server problem.  Look at the logs and see if there are some big logs that are growing very quickly.  Also - try and connect to the server admin pages - there is a diagnotics section in 4.x that will help identify the problem.  Does that report any problems?

You should also raise a ticket with support - as they can talk you through some more diagnostics as this is clearly a critical problem.

Forgot to ask - are you running this on a virtual machine? If so - check your vm memory settings are less than the real memory available on the machine.

Ralph Schoon commented Oct 30 '12, 5:50 a.m.

There is an issue with slow startup of CLM with running on isolate VMWares. The defect shows a work around.

I would also check the logs of your server and also review the files, especially for the public URI and the DB connection.

You should also always use a full qualified domain name in the public URI and also if you contact the server. That your server switched to the full qualified name isa good sign.

vinay kumar bondugula commented Oct 30 '12, 6:06 a.m.

 Thank you.

I am not using a virtual machine and my database is derby.
RAM on server-  4 GB.

I will run the diagnosis on the server and inform the results.

Ralph Schoon commented Oct 30 '12, 6:12 a.m. | edited Oct 30 '12, 6:13 a.m.

You said you are upgrading a production server. Derby is not intended to be used for production. It is for experimental and demo systems. Please consider to get a db2 community edition. Derby also limits to 10 developers (node locked license).

With respect to performance, please consider to check your machine RAM usage and performance implications. 4GB is not really a lot, dependent on what you deploy how....

YOGESH LOKHANDE commented Nov 19 '12, 1:29 a.m.
Application: the discovery resource at for "/rm" cannot be accessed:
The returned HTTP status was 500
The response body was
Invalid Configuration (Error list: Unable to retrieve "" application property) (More info found at entry [bfe985cb0c5a56b2] in RRS server log) Internal Error 500
showing 5 of 6 show 1 more comments

permanent link
Robby Elliott (311) | answered Oct 31 '12, 11:31 a.m.
Vinay we are currently experiencing the same type of issue with our deploy as well.  We opened PMRs and are currently working towards a solution.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.