It's all about the answers!

Ask a question

JTS 4.0 not starting (TomCat ?) on Windows 7

Scott Raley (13542931) | asked Oct 28 '12, 4:17 p.m.

similar to

I am having a similar problem. I'm trying to install it in Windows 7 and have 4 gigs of memory and it does the same thing as described above. I see the initial catalina parameters set and then the next popup dissapears. I have installed it on XP and it is running fine. Same machine configuration. I have followed a few articles on manually starting the tomcat service with tomcat7w.exe and have tried this but the article does not state how to get the packages deployed for JTS. with the tomcat service started I have tried running the start.bat and server.startup.bat and with the service already started I get a ton of errors in the dos window and then it dissapears. Anyone have suggestions if there is something in Windows 7? I am running it as administrator and running the command prompt as administrator.

Anthony Kesterton commented Oct 29 '12, 6:19 a.m.

Hi Scott

The sever.startup.bat is for when you don't have Tomcat running as a service - and wanting to start manually each time.  Are you trying to run Tomcat as a service?

Also - check which version of Windows 7 you are using - it requires at least Professional.

Finally, I have seen a JTS startup die when JTS is unable to write log files - check the server can actually write to the log directory.


Scott Raley commented Oct 29 '12, 6:39 a.m.

That was the problem. the JTS folder was set to read only for some reason. I was trying some of the RTC articles where you manually start tomcat as a service to try and get catalina and other things running. I just got through setup on JTS. Thanks

One answer

permanent link
sam detweiler (12.5k6195201) | answered Oct 28 '12, 4:38 p.m.
did you look at the

server logs


or tomcat logs


Scott Raley commented Oct 29 '12, 5:25 a.m.

the server/tomcat/logs is empty and there is no logs file in the server folder.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.