It's all about the answers!

Ask a question

Please help me with a solution for RQM - RPT integration issue.


Nishant Taksande (1169) | asked Aug 07 '12, 11:12 a.m.

I am using RPT 8.2 and  RQM 3.0.1 licenced version:

RPT--> Window\Preferences\Quality Manager Adapter

I have set the corret RQM server url, Login, Password, unique adapter name, project area and the RQM server is working fine.

1. When i try to connect to the RQM from RPT by clicking the connect icon in Quality manager adapter view; i get the following result.

1. Failed to login to the server. Reason: Unable to log into server: 408: http://10.12.21.168:9080/qm/web/consoleThe RQM Adapter has stopped.

2. Sometimes it connects and then try to reconnect many a times; please find the log

Adapter conected to the server.

Adapter successfully reconnected to the server.

Failed to register the adapter to the server.


Comments
Zhou Xing commented Aug 07 '12, 11:01 p.m.
JAZZ DEVELOPER

Hi Nishant, are you using IP in the url to connect to RQM server? if your RQM server's Root Public URL is set to use qualified domain name, then the url used in the adapter should be the qualified domain name too. Besides, make sure that the user you used in login RQM has the proper license and team member role, should be RQM connector or RQM professional license.

408 is a connection time out code, this might mean that the network between the adapter and RQM server is not connectable.

Hope this is helpful


Nishant Taksande commented Aug 08 '12, 1:21 a.m.

Hi Zhou Xing, thanks for the reply, i tried with the domain name in the URL, im using a floating licence for RPT, i am able to connect to RQM also in the manage licence view of RPT the licence key is available is displayed, still i am getting the same issue.


Nishant Taksande commented Aug 08 '12, 1:33 a.m.

hi Zhou Xing, i tried with a different user credentials, now i am geting the following messages 1.Adapter is successfully connected to the server. 2.Error occured while registering the adapter 3.Communication error with server.

And the messages are coming continuosly


Zhou Xing commented Aug 08 '12, 1:52 a.m.
JAZZ DEVELOPER

Hi Nishant, the user name and password are in English? and you might have a try to set this user as project area administrator. and also, please go to the adapter console in RQM to clear the adapters listed there to see whether can have this adapter registered successfully.


Nishant Taksande commented Aug 08 '12, 2:56 a.m.

Hi Zhou Xing i tried with the above, still the same error message, im losing it now.:)


Nishant Taksande commented Aug 08 '12, 2:58 a.m.

Actually Zhou, i did this a month ago using command line, the adapter connected, i imported the script, i executed the performance test sript, the reports and results were uploaded back to the RQM.

showing 5 of 6 show 1 more comments

3 answers



permanent link
Canberk Akduygu (99237071) | answered Aug 08 '12, 3:18 a.m.
You try to login  with Https protocol, why don't you try https://10.12.21.168:9443/qm

Comments
Nishant Taksande commented Aug 08 '12, 3:33 a.m.

I tried logging to RQM Server using the https, it doesnt work.


permanent link
Pramod Chandoria (2.1k11220) | answered Aug 09 '12, 1:07 p.m.
JAZZ DEVELOPER
Zhou Xing rightly said, Adapters are supposed to work with public URI, no ip address or other alias name should be used.
@Nishant make sure the public URI you use is the same used for server setup
User need not to be the administrator of the project, but member of it with appropriate permission to register adapter.

permanent link
Nishant Taksande (1169) | answered Nov 28 '12, 1:29 a.m.

Thanks You all,

The issue is solved, sharing some findings.

Any issue in the RPT RQM Adapter (failed to register, not getting conected and all)

Just make sure you are entering proper information in the RPT IDE \Preferences \ Quality Manager Adapter dialog

The solution of the issue is most of the times in these fields.

1. Server URL

Many a times the server URL changed and the and hence was the solution of the problem, you have to login to the Quality Manager with admin and you have to copy the same URL in the server URL dialog.

When using quality manager in a browser any link works like

http:\\<server ip>:port\qm

http:\\<server ip>:port\qm\web

http:\\<server ip>:port\qm\web\console

or

http:\\<server name>:port\qm\web

http:\\<server name>:port\qm\web

http:\\<server name>:port\qm\web\console

but for the adapter you have to use the "server URL configured in Rational Quality Manager"

2. Project Area

This is manadatory field, you have to copy it correctly from the project selection dialog while logging into RQM.

3. User id and Password

Make sure the specified user have "Test Team Member" rights.

4. Adapter name.

Keep it unique and simple :)

Your answer


Register or to post your answer.