It's all about the answers!

Ask a question

CRJAZ2336E while upgrading to RTC 4.0

Vivek Iyer (15212527) | asked Jul 31 '12, 2:53 p.m.
All, we hit this error while upgrading to 4.0.

The SQL Server database is configured incorrectly. The database might 
experience performance problems and become deadlocked.  For more 
details, open the help system and search for CRJAZ2336E.
Our admins followed the documentation on setting up an SQL Server Database and turned on row versioning. Now we're seeing the same error with the jazz DB (ccm/rtc) after changing the JTS db.

We have not found anything in the documentation on whether row versioning is supposed to be turned on with the jazz DB.

Has someone seen this error before? Will turning on row versioning in the other DB make this issue go away, or does this have larger implications for the upgrade process?



Mike Shkolnik commented Oct 01 '12, 7:10 p.m. | edited Oct 02 '12, 11:19 a.m.

The instructions I found specifically say the JTS database needs row versioning, not the CCM database. Which is correct? Or should they all have row versioning enabled? (CCM, JTS, RQ, DW) Also, is there a problem turning on row versioning in an upgraded database (from version 2 through 3 to 4)? I did not get this error after upgrading to version 3, but I am getting it in version 4.

See step 4 below, referencing jts database:

Craig Chaney commented Oct 01 '12, 9:45 p.m.

The sentence in step 1 that reads:

"Use the following example, substituting jts with your database name"

is intended to mean that each of those first four commands should be executed against the databases mentioned in step 1.

Rosa Naranjo commented Oct 02 '12, 11:18 a.m.

Mike, Craig is correct.  Each database associated with an application instance of CCM, QM, and JTS  needs row versioning.  The DW also needs it. All databases associated with the CLM solution need row versioning ALONG with everything else listed in the SQL setup topic.

Mike Shkolnik commented Oct 02 '12, 1:41 p.m.

I see the instruction in step 1 for substituting each database name, which clearly applies to the creation instructions in steps 1 and 2. However, since steps 3 and 5 apply to specific databases, it is not clear that step 4 applies to ALL databases. Are you certain of this? From the instructions of step 3 applying to only the JTS database and step 4 following that and referring to "the database", it implies it too only applies to the JTS database. Otherwise why not put the instruction that applies to all databases before the instructions that don't?

YOGESH LOKHANDE commented Nov 16 '12, 7:22 a.m. | edited Nov 16 '12, 11:19 a.m.


I have facing the same issue after upgrading CLM 3.0.1 to CLM 4.0.

I am also perfomr the Row Versioning for JTS and CCM ..

But still not working ....

Error is after
ID CRRRW7553E  A message that was received from the server indicates an error with no specific handler.
Unable to load /rm/rootservices?dojo.preventCache=1353068309041 status:500
Error: Unable to load /rm/rootservices?dojo.preventCache=1353068309041 status:500 at Object._28d [as resHandle] ( at func ( at _286 (

URL: /rm/rootservices

Error 500: Internal Server Error

Invalid Configuration (Error list: Unable to retrieve "" application property) (More info found at entry [8558cf9a639565f3] in RRS server log)

Requirements Management/4.0

Rosa Naranjo commented Nov 16 '12, 11:26 a.m.

This looks like an entirely different issue.  You seem to be failing during the RM Online migration.  If you backed up your JTS db prior to starting the RRC upgrade, you should be able to reattempt the upgrade.  You probably want to open a workitem against RRC and upload your rm.log, jts.log and other logs in the server directory related to the RRC offline migration.
There is one other file to include in the defect: migration-errors.log. RRC has its own upgrade results directory.  This directory will be found in the <server-install>/rdm/migration/systime-tmp directory. systime is a 13 digit number based on the time the migration ran.

showing 5 of 6 show 1 more comments

Accepted answer

permanent link
Craig Chaney (9212) | answered Aug 01 '12, 5:58 a.m.
You do indeed need to turn on row versioning for the CCM database.  Enabling row versioning after performing the upgrade is fine and will make the issue go away, there are no larger implications for the upgrade process.
Vivek Iyer selected this answer as the correct answer

YOGESH LOKHANDE commented Nov 19 '12, 12:33 a.m.

 I have trune on row Version but problem still there..

Cláudio de Sá Rodrigues commented Jan 12 '13, 1:41 p.m.

Also had the same problem after upgrading from to 4.0.1, but following tip from Craig (applied to the databases jts, ccm and qm) the problem was solved. Thank you!

2 other answers

permanent link
Michael Afshar (7014) | answered Jan 16 '13, 4:15 p.m.
The documentation was enhanced in 4.0.1:

permanent link
Diane Everitt (27835) | answered Feb 26 '14, 3:37 p.m.
If the error persists, check the database listed in Advanced Properties to ensure you are performing the command (step 4 in Setting up an SQL Server database) on the correct database.

For example:
Go to jts/admin > Server > Advanced Properties > > JDBC Location

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.