It's all about the answers!

Ask a question

Can two versions (v2 & v3) of Build System Toolkit be installed in parallel ?


Frank Herrmann (3113) | asked Jul 24 '12, 8:52 a.m.
Hi,
our team is using an RTC 2.x server just for tracking plans and workitems, but not for source control. However, we also use this RTC server to trigger our build using the Build System Toolkit/JBE connected from our build server to this RTC.

Now one subproject wants to move to a RTC 3.x server, while the other parts will remain RTC 2.x based. All (sub-) projects want to use the same build server. What are our options ?
- Can we install Build System Toolkit for RTC 3 in parallel to the v2 installation and then define an addl JBE based on v3 ?
- Can a v3 Build System Toolkit JBE work with a RTC 2.x server ?
- ?

Thanks for any insights you can provide!
regards,
   Frank

2 answers



permanent link
Moti Nisenson (2124) | answered Jul 24 '12, 11:59 a.m.
JAZZ DEVELOPER
There isn't backwards compatibility from JBE3 to JBE2.
It won't even pass the log-in stage, since JBE logs in to the RTC server like any other user; if you can't use an RTC version X client to connect to your server you can't use JBE version X either.

permanent link
Ralph Schoon (60.7k33643) | answered Jul 24 '12, 9:53 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
As far as I know you have to upgrade the JBE with the server. Since you can only upgrade the complete server there is no way of upgrading only sub projects, unless you run several RTC servers.

If you have several servers, you could install JBE2 and JBE3 in parallel in different folders e.g. using the zip version or even the IM version. you can run the JBE's in parallel and connect JBE2 to a RTC 2 server and JBE3 to a RTC 3 Server.

Your answer


Register or to post your answer.