It's all about the answers!

Ask a question

Test connection fail in RTC 4.0

Jesse Timbang (3211619) | asked Jul 23 '12, 1:42 p.m.
retagged Jan 29 '14, 2:56 p.m. by Scott Cowan (966310)
We have RTC4.0 and wanted to experiment with Hudson. So, following the steps in this url:

I have started Hudson on my local machine (localhost:8080), but the Eclipse client doesn't seem to detect it. When clicking the Test connection button it just says:

Connection test requested.
    Connecting to: http://isd-pbfycb3:8080/
Exception: isd-pbfycb3    Test connection FAILED!

I have tried: localhost, my ip address, my computer name, but it doesn't seem to detect the Hudson server.
In RTC 3.0 I was able to do something similar, but with 4.0, Hudson is now one of the choices. Am I missing something here?

Eitan Shomrai commented Jul 27 '12, 10:46 a.m. | edited Sep 17 '13, 3:44 p.m.

I've just installed  Jenkins ver. 1.475 and the engine CAN connect and I get:
Connection test requested.
    Connecting to: http://<host-name>:8080
    Found header: X-Jenkins - 1.475
    Found header: X-Hudson - 1.395
    Test connection SUCCESSFUL!

 but I cannot save the Hudson/Jenkins tab in the build definition as the "Get jobs" button fails and the Job Section is empty.
Any idea?

Jesse Timbang commented Jul 27 '12, 10:50 a.m.

Well, we've taken Hudson out of the equation and we are now looking at the Jazz build Engine to do our builds for us. So far so good.

Ralph Schoon commented Jul 27 '12, 2:11 p.m. | edited Sep 17 '13, 3:45 p.m.

I would assume you have to set up a job - no idea how to do that. Have you looked into the RTC and Jenkins help?

Eitan Shomrai commented Jul 28 '12, 3:30 p.m.

I've put the solution in the discussion section of the original instruction in The issue was caused by trying to set "Jazz Source Control" in the Build definition and not as it said to push Finish (and not going to pre/post build screens). By the way I've installed the Jenkins plugin for RTC and it works great with V4!

Alex Rodriguez commented Sep 17 '13, 2:13 p.m. | edited Sep 17 '13, 3:44 p.m.

I am getting the same issue or similar described here. I am setting a jenkins/RTC CI in my localhost, I am able to see the jenkins GUI in the browser (firefox) but when a create the build engine and test the connection I am getting the following error:

Connection test requested.
Connecting to: http://localhost:8080
Exception: Connection refused: connect Test connection FAILED!

I have set the proxy server to my company proxy in the preference menu under general > Network Connection, also I am able to deliver changeset, etc. I also checked the etc/hosts file and I can see localhost is mapped to

I have Helios + cpp, rtc 4.0.3, linux is as follows (uname):
Linux <machine name> 2.6.18-348.1.1.el5 #1 SMP Fri Dec 14 05:25:59 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

I could provide some logs but I don't know how to enable such feature or where are they located.

4 answers

permanent link
Scott Cowan (966310) | answered Jan 29 '14, 2:15 p.m.
Oh Jesse, this is too bad.

I wish I'd seen this thread earlier.  I have opened this defect, Clarify that the Hudson/Jenkins build engine connection test runs on the RTC server, not the client machine (300237).

In short, the problem is most likely due to the fact that the connection test is run from the RTC server, and so it must be able to reach the hudson/jenkins server URL.  If the RTC server is outside a firewall it will not reach the hudson/jenkins server.  Also if the h/j server is installed on your local machine and you enter a URL of http://localhost:8080 it will resolve to the RTC server machine, not your local client machine.

I hope that is the problem you saw, and I'm sorry we didn't get you the correct information earlier.

permanent link
Duzgun Aral (1122) | answered Jan 22 '14, 5:45 p.m.
 We have the same issue and can't figure out what the problem is. Did you ever find a solution?

Jesse Timbang commented Jan 29 '14, 5:54 a.m.

No unfortunately. We ditched the hudson part and went along with the JBE. 

permanent link
Ralph Schoon (63.3k33646) | answered Jul 24 '12, 3:01 a.m.
Can you open the page with a browser? Have you tried to add the host to the etc/hosts (if you don't have DNS)? Are you sure about the port Hudson uses? Is Hudson running and working?

Jesse Timbang commented Jul 24 '12, 3:45 a.m. | edited Sep 17 '13, 3:43 p.m.

Yup, I can open up the Hudson web ui in a browser and it is running. Tried changing ports too by java -jar hudson.war --httpPort=<PORT_NUMBER> when starting it.

permanent link
Ralph Schoon (63.3k33646) | answered Jul 24 '12, 1:39 a.m.

the article mentions the URL to Hudson looks like http://<host>:<port>/hudson. Have you tried that? The error could be misleading.

Jesse Timbang commented Jul 24 '12, 2:10 a.m. | edited Sep 17 '13, 3:43 p.m.

Yes, I've tried that as well.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.