It's all about the answers!

Ask a question

Permission Problem after upgrade to RQM 4.0

Bin Chen (41911) | asked Jul 13 '12, 4:36 p.m.
 I have recently upgraded RQM to RQM 4.0. After the upgrade, none of the users can access existing projects any more: the following is displayed when user is trying to open a project:

We're Sorry...

You do not have permission to view this dashboard. ID CRJAZ5026I
The owner of this dashboard has not granted you access to view it.
If you believe you should have access to this dashboard, contact the owner to request permission.

Accepted answer

permanent link
Pramod Chandoria (2.1k11220) | answered Jul 14 '12, 6:41 a.m.
Hi Bin
You can also look for similar issue reported in part and see if that solves your problem
Unable to access dashboard after upgrading to RQM 4.0RC2 (66874)

If not then PMR would be the right approach as Ralph mentioned above.
-|- Pramod Chandoria
Bin Chen selected this answer as the correct answer

Bin Chen commented Jul 16 '12, 1:18 p.m.

Thank you, I think RM was indeed the issue in my case.

After that I ran RM upgrade script, the script prompt me to run migrate wizard and I did not do it.

So this is what I did: un-install RM application, re-run RM upgrade script, run migration wizard as the script asked me to; install RM. Then I had also modify trust relationship under jts/admin/server consumer(Inbound) and made a few more thing trusted.

Pramod Chandoria commented Jul 16 '12, 1:33 p.m.

Good to know your problem is resolved :)

One other answer

permanent link
Ralph Schoon (63.2k33646) | answered Jul 14 '12, 6:38 a.m.

I would suggest to open a PMR or work item.

Some thoughts.
- Is the administrator able to look at data?
- Which app server are you using? Provide more information about your environment, OS, DB,....
- What is used for authentication? LDAP, Tomcat?
- What does the diagnostics page show (JTS and QM)?
- Anything in the upgrade logs?
- Anything in the server logs?
- Have you tried to add more logging in the Log4J configuration?

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.