It's all about the answers!

Ask a question

Error: Incorrectly typed parameter submitted to query;

A B (881811) | asked Oct 18 '11, 11:24 a.m.
Hello everyone,

We are trying to find workitem Id's programatically using JAva code with following Code(only relevant portion):

AttributeExpression dueExpression= new AttributeExpression(attribute, AttributeOperation.EQUALS,SMS_ID.get(y));

System.out.println("Inside for loop 2 ");

Term term= new Term(Operator.AND);

IQueryResult<IResolvedResult<IWorkItem>> result= queryService.getResolvedExpressionResults(projectAreaHandler,term, profile);

List<IWorkItem> matchingWorkItems= new ArrayList<IWorkItem>(result.getResultSize(monitor).getTotalAvailable());

But execution of Second line of code gives following error:

Incorrectly typed parameter submitted to query; 

Parameter 1 was class java.lang.String but was expected

Intrestingly this code worked perfectly fine for other repositories. Any idea on what could be the cause, solution or any pointer?



One answer

permanent link
A B (881811) | answered Oct 19 '11, 3:10 a.m.
Hello everyone

Just did some more analysis and it seems that issue comes only for some of the fields. The one change which we can see in this new PA is that type of these fields is now big string.

We also tried to change the data type back to small string but it still dont works. Any ideas, pointers will be highly appreciated.


mark owusu-ansah commented Aug 20 '13, 9:58 p.m.

    Were  you ever able to get  this to work?  Clearly it is a misappropriated error.
 I have  the same issues and cant seem to get to the  cause of it.

Your answer

Register or to post your answer.