It's all about the answers!

Ask a question

Connection and library cleared in iProject


Melissa Weaver (621215) | asked Sep 27 '11, 6:52 p.m.
retagged Jun 23 '12, 5:47 p.m. by Arne Bister (2.6k12832)
We have had a problem where a previously defined connection and library on a iproject get cleared (Properties, iProject). You cannot do it yourself as it is a required field. Does anyone have any idea what would cause this to happen. We suspect it may be caused by our encryption program - but that is just a hunch.

3 answers



permanent link
Melissa Weaver (621215) | answered Jul 29 '15, 5:37 p.m.
 The encryption setting were changed to NOT encrype any of the RTC libraries, especially the settings.  This resolved the problem.  Problem appears to be that the encryption was locking the configuration file, so RTC thought it was missing and set everyhing back to the defaults. 

permanent link
Melissa Weaver (621215) | answered Sep 28 '11, 11:53 p.m.
Yes each developer has set their own library and connection. On two developers workstation it was set correctly for several months, and then it suddenly was cleared. Other developers did not have a problem.

Hi Melissa,

When you share an IBM i Project the connection and library information are not shared. This means that everyone who loads the IBM i Project will need to set their own Library and Connection. This is the only time I have heard about people missing the library and connection information.

We have had a problem where a previously defined connection and library on a iproject get cleared (Properties, iProject). You cannot do it yourself as it is a required field. Does anyone have any idea what would cause this to happen. We suspect it may be caused by our encryption program - but that is just a hunch.

permanent link
Kevin Doyle (60425) | answered Sep 28 '11, 9:32 p.m.
JAZZ DEVELOPER
Hi Melissa,

When you share an IBM i Project the connection and library information are not shared. This means that everyone who loads the IBM i Project will need to set their own Library and Connection. This is the only time I have heard about people missing the library and connection information.

We have had a problem where a previously defined connection and library on a iproject get cleared (Properties, iProject). You cannot do it yourself as it is a required field. Does anyone have any idea what would cause this to happen. We suspect it may be caused by our encryption program - but that is just a hunch.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.