It's all about the answers!

Ask a question

Ptoblem trying to restore RTC backup

Robin Parker (32633638) | asked Dec 03 '10, 1:34 p.m.
Hi all,

I'm in the process of setting up backup and restore procedures for our RTC install.

The process should be pretty os/db agnostic:

Back up the server/conf directory (except the site, provision_profiles and derby directories)
Back up the server/tomcat/conf directory.

Use repotools-jts -export to back up the JTS database.
Use repotool-ccm -export to back up the ccm database.

At the moment, I'm trying to restore using the following process - This is onto a different machine.

Reinstall RTCV3 from scratch.
Start the server
Run through the server Setup
Shut down the server
Copy the tomcat-users.xml file from the backup
restore the ccm database using repotools-ccm -import
restore the jts database using repotools-jts -import
start the server
run through the setup

Voila!! - in theory...

This works mostly until I get to the final setup. The ccm application is recognised as already registered and I don't have the opportunity to change it. So, after the setup, I go into the server admin and the registered applications section and there it is, with the wrong discovery URL.
Clicking on the edit button seems to offer the opportunity to change the url. However, when I change it and click Finish, the url doesn't appear to have been updated.

I then try and run setup again. This time after the register applications page I can go on and view the ccm setup pages - including the public uri page which I can set to the correct public uri. Hooray! - I've cracked it!

So, I run through to the end of the setup. When I click finish, I'm taken to the admin page and go to the registered applications page. There is the CCM application still with the original incorrect discovery uri listed and I can't access the ccm application from the house icon either, it says 'This application is not configured for communication with <wrong> . If you are an administrator, please run the Jazz Team Server setup wizard.

I've tried running the setup a number of times and I've looked through the admin web pages and other than the things I've already tried, I can't find another way to update the URI of the CCM application.

Am I running into a bug here?


2 answers

permanent link
Robin Parker (32633638) | answered Dec 03 '10, 2:05 p.m.
Yes, that looks similar to what I did.

I tried removing ccm as a registered application which seemed fine.

I then tried registering it again but got an error because the jts server was already registered in the ccm server. So I removed the jts server from the friends page of the ccm server and then I could add the ccm server to the jts and run through th setup properly.

I don't seem to have my dashboards though so hmmm, not sure about that ...

permanent link
Fabrice Dumay (1122) | answered Dec 03 '10, 1:59 p.m.

Did you tried the solution from
Last post from John Vasta.

He helped me.

Your answer

Register or to post your answer.