It's all about the answers!

Ask a question

Error installing RTC - Client for Eclipse IDE


Giuseppe Nettis (3653) | asked Nov 03 '10, 9:16 a.m.
Hi to all,
when i try to install RTC - Client for Eclipse IDE from web install through IBM Installation Manager, i have this error:

Impossibile installare l'offerta in questa configurazione di installazione Eclipse poich invaliderebbe i vincoli di bundle esistenti
L'installazione del bundle "org.eclipse.xsd_2.5.0.v200906151043" in questa installazione Eclipse esistente non corrisponde alla tolleranza di versione "[2.6.0,3.0.0)" per il bundle esistente "org.eclipse.xsd.edit"
L'installazione del bundle "org.eclipse.emf.edit_2.5.0.v200906151043" in questa installazione Eclipse esistente non corrisponde alla tolleranza di versione "[2.6.0,3.0.0)" per il bundle esistente "org.eclipse.xsd.edit"

I try to install the client RTC 3.0RC2 in a clean Eclipse Helios for RCP developers

Any suggestion?
Thanks
Giu

2 answers



permanent link
Raphael Weisser (10195) | answered Nov 03 '10, 10:41 a.m.
Hi,
I had the same problem this morning too.
Try this:

In your Eclipse-Helios
Help > Install New Software
Select "Helios - http://download.eclipse.org/releases/helios" from the list in top of the window.
Extend "Modeling" and choose "XSD - XML Schema Definition SDK"

This will install the current version 2.6.0, which is accepted by the IM

EDIT: This will only fix your first failure
Maybe the EMF-Eclipse Modeling Framework SDK in the same install-package could help you

permanent link
Giuseppe Nettis (3653) | answered Nov 04 '10, 3:36 a.m.
Thanks a lot, that's ok now.
However, i have problems if i try to install other languages.. i have error in some packages like, for example, emf.

Hi,
I had the same problem this morning too.
Try this:

In your Eclipse-Helios
Help > Install New Software
Select "Helios - http://download.eclipse.org/releases/helios" from the list in top of the window.
Extend "Modeling" and choose "XSD - XML Schema Definition SDK"

This will install the current version 2.6.0, which is accepted by the IM

EDIT: This will only fix your first failure
Maybe the EMF-Eclipse Modeling Framework SDK in the same install-package could help you

Your answer


Register or to post your answer.