It's all about the answers!

Ask a question

2.x to 3.0RC2 Migration Question


Robin Parker (32633638) | asked Oct 28 '10, 6:21 a.m.
I'm following these instructions:
https://jazz.net/wiki/bin/view/Main/RTCtoCCM30MigrationSteps

We're using DB2 for the JAZZ database and will be using DB2 for the JTS database.

I notice that after running the command
repotools-jazz.bat -clean -migration_updateConfigurationFiles oldJazzHome=<RTC2>/server/conf 



that in the server\conf\jazz\teamserver.properties file there is a DERBY database specified for the datawarehouse.

This not mentioned in the migration guide. Should this be set up on DB2 as well?

2 answers



permanent link
Robin Parker (32633638) | answered Oct 28 '10, 11:43 a.m.
I just had a very weird problem.

The migration failed consistently in step 3 of the rtc_migration.bat file with errors such as this....

CRJAZ1093I The following service class was not activated: "com.ibm.team.repository.service.jts.internal.userregistry.Ext

ernalUserRegistryInternalService"


I tried recreating the database, even reinstalling 3.0RC2 server from scratch to no avail.
This was strange because I'd done successful migrations in a VM using a repotools backup of or repository as data.

I eventually tracked this down to an entry in the conf\jts\teamserver.properties file.

The entry was
com.ibm.team.repository.user.registry.type=TOMCAT


whereas on the VM, which I luckily hadn't reverted to snapshot it was ...

com.ibm.team.repository.user.registry.type=DETECT


I changed this entry and reran step 3 of the rtc_migration.bat script and it seemed to work OK.

I haven't figured out where the difference came from yet. If anyone has any ideas? ...

permanent link
Milan Krivic (9809165136) | answered Oct 28 '10, 5:46 p.m.
I just had a very weird problem.

The migration failed consistently in step 3 of the rtc_migration.bat file with errors such as this....

CRJAZ1093I The following service class was not activated: "com.ibm.team.repository.service.jts.internal.userregistry.Ext

ernalUserRegistryInternalService"


I tried recreating the database, even reinstalling 3.0RC2 server from scratch to no avail.
This was strange because I'd done successful migrations in a VM using a repotools backup of or repository as data.

I eventually tracked this down to an entry in the conf\jts\teamserver.properties file.

The entry was
com.ibm.team.repository.user.registry.type=TOMCAT


whereas on the VM, which I luckily hadn't reverted to snapshot it was ...

com.ibm.team.repository.user.registry.type=DETECT


I changed this entry and reran step 3 of the rtc_migration.bat script and it seemed to work OK.

I haven't figured out where the difference came from yet. If anyone has any ideas? ...


Can anyone suggest some useful link about upgrading RTC 2.x to RTC 3.0 RC2 with complete steps?
I compared some steps from jazz wiki and rtc 3.0 tutorial which is still under construction, and it seems they don't match...

Your answer


Register or to post your answer.