It's all about the answers!

Ask a question

Anyone successfully adding rtc_cm attributes via REST in M8?

Sean G Wilbur (87212421) | asked Sep 06 '10, 11:27 a.m.
I have a custom work item attribute that I am setting externally and passing to RTC as an XML document via the REST API. This was working correctly for 3.0m7a, I upgraded to 3.0M8 and started validating the changes and noticed that even though I am putting the field in the XML it is not being accepted by RTC, in this case I get an error that the attribute requires a value, which makes sense because it is mandatory.

I tried a simple test for a new record with out luck, and also have grabbed and existing record as XML updated the XML and put that back to the server without luck for this particular attribute ? I have double checked the attribute id, tried with json as well and no luck any suggestions or do I need to change the namespace for custom rtc work item attributes? I am using rtc_cm:* but I also tried oslc_cm:* and calm:* just in case.

Any suggestions are welcome.


One answer

permanent link
Sean G Wilbur (87212421) | answered Sep 07 '10, 10:18 a.m.

Your answer

Register or to post your answer.