It's all about the answers!

Ask a question

RTC 2.0.02 IFIX3 with Visual stodio - repo ws marked unload


Yaron Norani (47267064) | asked Aug 04 '10, 3:49 a.m.
Hello,

I have a sandbox loaded and everything works fine for several days.
Today I tried to open VS solution (that works fine and managed) and gets a message that it is not loaded.
Also I see at the team atrifacts that the component marked as not loaded.
Why does it happen?

I did not want to load again and overide my local changes.
At the end I have performed load -> do not load anything. only track changes, and it corrcted the problem.

Why does it happen?

Thanks,

Yaron Norani

3 answers



permanent link
Prabodh Mairh (3812) | answered Aug 04 '10, 3:00 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hello,

I have a sandbox loaded and everything works fine for several days.
Today I tried to open VS solution (that works fine and managed) and gets a message that it is not loaded.
Also I see at the team atrifacts that the component marked as not loaded.
Why does it happen?

I did not want to load again and overide my local changes.
At the end I have performed load -> do not load anything. only track changes, and it corrcted the problem.

Why does it happen?

Thanks,

Yaron Norani


Hi,
Do you have the loaded files present in sandbox, even though the client shows the workspace/component unloaded? Because if component is unloaded from VS client, the files are also deleted from the sandbox (It is however possible through RTC Eclipse client to unload component leaving behind the local files). So my guess would be, that component is not actually unloaded but the projects are not being tracked for some reason.
Can you open the solution and see if it is still shared using Jazz source control. Please unshare/share the solution, this will write the bindings again.

permanent link
Yaron Norani (47267064) | answered Aug 05 '10, 4:45 a.m.
Hello,

I have the components loaded. I mean the the files exist at the sandbox. But as you said, from some reason it is marked as unloaded.

I need to know what is the meaning of "from some reason".
To correct it I performed "load" and then chose the "only track..". Afterwards the component was marked as "loaded".

Thanks,

Yaron Norani

permanent link
Walter Mansur (63613017) | answered Aug 05 '10, 10:24 a.m.
Hi,

You do not state what version of RTC you are using. For this discussion, I will assume that you are using RTC v2.0.0.2.

We are using RTC v2.0.0.2 with iFix2 here. We had a similar issue to this and there is a Work Item for it - Work item 114291. It is marked as resolved by IBM for RTC v3.0 (due out in October 2010) and for RTC v2.0.0.2, iFix3 (this is available now).

Something that may be helpful to you is this:

When using the RTC Visual Studio Client, in order to see "loaded" workspaces, you need to do one of three things. All 3 of these items are displayed when you open up the RTC Client for Visual Studio.

1. Open up a Visual Studio solution that is under RTC source control.
2. Open up the Team Artifacts view in the RTC Visual Studio Client and perform a "load" action on a workspace (i.e. load nothing, changes will be tracked...).
3. Share a solution from the Solution Explorer window. That is, you would open up a solution in a workspace that is not "Shared in Jazz " and perform the "Share Project(s) in Jazz" action on it. (It is possible to have such a solution in a workspace on your local workstation).

We usually do what is described in #1 above. That shows us the last workspace(s) that we worked in, which is what we want. If we want to see any other ones , then we have to do what is described #2 above.

Based on your post here it appears that you are using #2 above to see your workspaces as "loaded". This is just the way that it works for the RTC Client for Visual Studio, for now.

- Walter

Hello,

I have the components loaded. I mean the the files exist at the sandbox. But as you said, from some reason it is marked as unloaded.

I need to know what is the meaning of "from some reason".
To correct it I performed "load" and then chose the "only track..". Afterwards the component was marked as "loaded".

Thanks,

Yaron Norani

Your answer


Register or to post your answer.