It's all about the answers!

Ask a question

JBE failed to build a scheduled request


Andrea Chu (61) | asked May 27 '10, 4:52 a.m.
I set up a build engine and a build script on RTC. The build script is running fine if the build request is sent by user but scheduled request.

Once the jazz build engine received the scheduled request, it responded "no pre-build participants that want to build".

2010-05-27 07:28:17 Sleeping for 30 seconds...
2010-05-27 07:28:49 Searching for build request...
2010-05-27 07:28:51 Found a scheduled request for build definition "TEAM - SERVER BUILD".
2010-05-27 07:28:52 Should build occur?
2010-05-27 07:28:56 No: There are no pre-build participants that want to build.
2010-05-27 07:28:56 Build "20100527-0728" not necessary.

It seems that the Pre-build participant "com.ibm.team.build.jzaascm" is missing.
Can I check and configure this setting?

Thanks

2 answers



permanent link
Andrea Chu (61) | answered May 27 '10, 10:27 p.m.
It works! Thanks for checking and the explanation!

permanent link
Nick Edgar (6.5k711) | answered May 27 '10, 1:07 p.m.
JAZZ DEVELOPER
It sounds like you have the 'Build only if there are changes accepted' option checked in the Jazz Source Control page of the build definition.

When this is checked, if there are no new changes in the stream (and no other participant says that a build is required) the build simply gets deleted as not needed.

If you want it to run regardless of whether there are new changes, just uncheck that option.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.