It's all about the answers!

Ask a question

EWM query attribute "workitem" missing value "Unassigned"


Alexander Burk (2727) | asked Aug 30 '23, 5:53 a.m.
Hello,

in EWM 7.0.2 we can define custom attributes of type "workitem" and query for that. In our case, we have a work item type "Bug" and added the custom attribute "Detected In" of type workitem to it. We'd like to query for all Bugs, that have no "Detected In" value (=work item) set.

Unfortunately, this seems to be not possible. There is no "Unassigned" checkbox or similar for that available.

Query for attribute Detected In is Unassigned

I already looked at the Advanced user guide to querying work items but found no solution there.

Anyone got any work around available for the use case? Is it a bug, a new feature request?

Thank you,
Alex

2 answers



permanent link
Krzysztof Kaźmierczyk (7.4k372103) | answered Nov 09 '23, 8:55 a.m.
Hi Alexander,
There is no option out of the box, but I found the following work around:
Check the creation date for work item type - see message below.
I put very early date. If the work item does not exis, then it does not match this criteria.

Let us know if that helped you.
Creation date after 1970

Comments
Alexander Burk commented Nov 10 '23, 6:20 a.m.

Hi Chris,

the proposed work around returns a list with items that have a work item set.

We need the list of items with no work item set in the attribute.


permanent link
Ralph Schoon (63.0k33645) | answered Sep 11 '23, 3:27 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 I would suggest to file an enhancement request. You might want to open a case with support to check. If it works a s designed and requires an enhancement request, you will be provided with how to. 

Your answer


Register or to post your answer.